Bug 30862 - Custom Install crashed after monitor selection before video card selection
Custom Install crashed after monitor selection before video card selection
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-06 15:59 EST by John DeHority
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-14 11:26:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John DeHority 2001-03-06 15:59:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en]C-CCK-MCD {Kodak_1.461_3}  (WinNT; U)


This is approximately the same place that the "workstation install" crashed earlier today.
I've gotten far enought to reformat the disks so my previous  6.1 install is now history.
I crashed in a similar spot attempting an "upgrade", and decided to try a clean install.

Reproducible: Always
Steps to Reproduce:
1.Custom Install on IBM 755Cse laptop
2 choose monitor type 
3.had not selected video card yet

	

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/xconfig_gui.py", line 408, in getScreen
    self.cards = self.todo.x.cards ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/xf86config.py", line 659, in cards
    db = open ('/usr/X11R6/lib/X11/Cards')
IOError: [Errno 2] No such file or directory: '/usr/X11R6/lib/X11/Cards'

Local variables in innermost frame:
server: W32
self: <xf86config.XF86Config instance at 829bd18>
cards: {'Generic I128': {'SERVER': 'I128', 'NAME': 'Generic I128'}, 'Generic W32': {'SERVER': 'W32', 'NAME': 'Generic W32'}, 'Generic Mach64': 
{'SERVER': 'Mach64', 'NAME': 'Generic Mach64'}, 'Generic Mach8': {'SERVER': 'Mach8', 'NAME': 'Generic Mach8'}, 'Generic Mono': 
{'SERVER': 
'Mono', 'NAME': 'Generic Mono'}, 'Generic Mach32': {'SERVER': 'Mach32', 'NAME': 'Generic Mach32'}, 'Generic 3DLabs': {'SERVER': '3DLabs', 
'NAME': 'Generic 3DLabs'}, 'Generic S3V': {'SERVER': 'S3V', 'NAME': 'Generic S3V'}, 'Generic FBDev': {'SERVER': 'FBDev', 'NAME': 'Generic 
FBDev'}, 'Generic P9000': {'SERVER': 'P9000', 'NAME': 'Generic P9000'}, 'Generic SVGA': {'SERVER': 'SVGA', 'NAME': 'Generic SVGA'}, 
'Generic S3': {'SERVER': 'S3', 'NAME': 'Generic S3'}, 'Generic 8514': {'SERVER': '8514', 'NAME': 'Generic 8514'}}
thecard: None

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Brent Fox 2001-03-07 11:54:29 EST
Is this a cd that you burned yourself?  If so, I think something went wrong
during either the download or the burning of the cd.  The program is crashing
because it's trying to look up your video card in the cards database, and it
can't find the database.  This should never happen, because the cards database
is always distributed with Red Hat Linux.  You might try using text mode and
then skip configuring the video card, however, if the cd is bad, I would
encourage you to download again and burn a new cd.  Can you run md5sum on the
iso image and see if it matches the md5sum of the iso images on the ftp site?
That will let you know if there were errors in the download.
Comment 2 Brent Fox 2001-03-14 11:07:40 EST
Hello.....
Comment 3 John DeHority 2001-03-14 11:26:05 EST
The failure is consistently on a file open. I now suspect that the failure is due to the aging CD-ROM drive on this system.
With increaseing frequency it takes a couple tries for it to seek to and open a file. I expect the retries are causing a timeout in the 
open file routine of the install scripts.

I've had simular failures with 3 different sets of CDs: a genuine RedHat 7 CD, a set we burned from a network download, and a set that 
came with a "Learn RedHat Linux in a Weekend" book. I'm almost certain the problem is with the hardware. A longer timeout in the open
might might work around it, but I'll find a local fix--either replacing the CD-ROM drive or using a network install.

Thanks
Comment 4 Brent Fox 2001-03-14 11:37:16 EST
Yeah, that sounds right to me.  When the installer can't find files, usually
it's a bad cd, a bad download, or bad hardware.  There's no other reason for a
file that is a part of the installer not to be found.

Note You need to log in before you can comment on or make changes to this bug.