Bug 30866 - Wrong mouse section in XF86Config file
Summary: Wrong mouse section in XF86Config file
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: Xconfigurator (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-06 21:17 UTC by Sammy
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-16 01:46:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2001-03-06 21:17:33 UTC
It seems like the new kudzu modifies my /etc/X11/XF86Config file
in a way to crash the X server....first of all any modifications
to this file should save a XF86Config.rpmsave file. Basically big
error is that a the file is missing a Section "InputDevice" statement
before the mouse definitions. Here is the diff between the "wrong"
and correct files:

$ diff XF86Config-4 XF86Config-4.wrong
206c206
< Section "InputDevice"
---
>     Device    "/dev/mouse"
212,213c212,213
<     Option "Protocol"    "PS/2"
<     Option "Device"      "/dev/psaux"
---
>     Protocol    "PS/2"
>     Device    "/dev/mouse"
330,331c330,331
<     InputDevice "Mouse1" "CorePointer"
<     InputDevice "Keyboard1" "CoreKeyboard"
---
>     Device    "/dev/mouse"
>     Device    "/dev/mouse"

Comment 1 Bill Nottingham 2001-03-06 21:20:59 UTC
kudzu doesn't directly touch X configuration files; most likely it's
an Xconfigurator or mouseconfig problem.

Can you post the 'diff -u' format diff?

Comment 2 Sammy 2001-03-07 14:13:51 UTC
# diff -u XF86Config-4.0 XF86Config-4.wrong
--- XF86Config-4.0      Tue Mar  6 14:32:35 2001
+++ XF86Config-4.wrong  Tue Mar  6 14:28:53 2001
@@ -203,14 +203,14 @@
 # Core Pointer's InputDevice section
 # **********************************************************************
 
-Section "InputDevice"
+    Device     "/dev/mouse"
 
 # Identifier and driver
 
     Identifier "Mouse1"
     Driver     "mouse"
-    Option "Protocol"    "PS/2"
-    Option "Device"      "/dev/psaux"
+    Protocol    "PS/2"
+    Device     "/dev/mouse"
     Option "Buttons"     "3"
     Option "ZAxisMapping"  "4 5"
 
@@ -327,8 +327,8 @@
 # used.  Those options include "CorePointer", "CoreKeyboard" and
 # "SendCoreEvents".
 
-    InputDevice "Mouse1" "CorePointer"
-    InputDevice "Keyboard1" "CoreKeyboard"
+    Device     "/dev/mouse"
+    Device     "/dev/mouse"
 
 EndSection

Comment 3 Preston Brown 2001-03-28 20:07:10 UTC
we haven't been able to duplicate this, and I am not sure how it happened.  It 
looks like XFree86 3.3.6 instructions were written to your 4.0.x config file.  
Examining the code, I really can't see how this happened, unless you perhaps 
have the two files in /etc/X11 symlinked together.



Note You need to log in before you can comment on or make changes to this bug.