Bug 30940 - memory alloc(2554682469 bytes) returned NULL.
memory alloc(2554682469 bytes) returned NULL.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0tc
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 04:50 EST by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 04:51:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-07 04:50:55 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98)


rpm -i "any rpm file" shows message "memory alloc(2554682469 bytes) 
returned NULL" and can't install. rpm --rebuilddb shows the same. I use 
RedHat7.1RC1. After I install the java-1.1.8.rpm from SuSe7.1, I got this 
problem.

Reproducible: Always
Steps to Reproduce:
1.rpm -i "a package"
2.rpm -qa
3.any rpm command
	

Actual Results:  I can't install, upgrade,nor delete a package

Expected Results:  Should be able to install,upgrade and delete a package

I have installed java1.1.8.rpm from SuSe 7.1 CDROM
Comment 1 Jeff Johnson 2001-03-08 14:14:42 EST
This is a package problem, not an rpm problem. rpm is reading the two ints from
the package metadata that describe the size of the metadata, and, for reasons
known only to the person who created the package, the values are wrong,
possibly because of a little-endian/big-endian ordering problem.
Comment 2 Need Real Name 2001-04-27 03:55:58 EDT
I have encountered a similar problem though my malloc goes from 28 bytes to 
286261256 bytes.  I encounter this message:

[root@shadow /root]# rpm -qa
... (lists *nearly* all my rpms)
memory alloc (286261256 bytes) returned NULL.
[root@shadow /root]#

I am able to install packages, receive information/filelists of installed 
packages (rpm -qi/rpm -qil), and uninstalled packages.  My only problem is a 
query of all package names installed.  This occured while using kpackage and 
kpackage refuses to start after this occured.

Note You need to log in before you can comment on or make changes to this bug.