Bug 309441 - unrecognized video card: Radeon HD 2400PRO (Asus EAH2400PRO/HTP/256M)
unrecognized video card: Radeon HD 2400PRO (Asus EAH2400PRO/HTP/256M)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vesa (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 13:50 EDT by Jim Meyering
Modified: 2013-03-13 16:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-03 09:22:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
log when using DVI cable, booting with xdriver=vesa (78.18 KB, text/plain)
2007-09-27 13:50 EDT, Jim Meyering
no flags Details
log (12.55 KB, text/plain)
2008-01-12 06:09 EST, Jim Meyering
no flags Details
Xorg.0.log (72.75 KB, text/plain)
2008-01-18 07:17 EST, Jim Meyering
no flags Details
xorg.conf (1.11 KB, text/plain)
2008-01-18 07:24 EST, Jim Meyering
no flags Details
log using -ati driver and Dell 2001FP (95.53 KB, text/plain)
2008-03-31 04:05 EDT, Jim Meyering
no flags Details
new log, now w/Option "ModeDebug" "true" (77.29 KB, text/plain)
2008-04-23 13:54 EDT, Jim Meyering
no flags Details
retried with same config as above (94.45 KB, text/plain)
2008-05-16 06:38 EDT, Jim Meyering
no flags Details

  None (edit)
Description Jim Meyering 2007-09-27 13:50:36 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Using this card, Radeon HD 2400PRO (Asus EAH2400PRO/HTP/256M), the F8T2 ISO,
just installed, and boot with "xdriver=vesa"

Steps to Reproduce:
1.
2.
3.
  
Actual results:
(DVI mode: screen blanks and Dell FP2001 says something like "cannot display
this mode")  When I tried it with VGA cable, I got decent images, but it was
offset to the right by about 1/2 the screen, so I couldn't complete installation
(with the "Next" button in lower right being off the screen -- and couldn't
adjust horiz. to compensate for that)

I get this in lspci output:
03:00.0 VGA compatible controller: ATI Technologies Inc Unknown device 94c3

Expected results:


Additional info: Xorg.0.log attached
Comment 1 Jim Meyering 2007-09-27 13:50:36 EDT
Created attachment 208781 [details]
log when using DVI cable, booting with xdriver=vesa
Comment 2 Jim Meyering 2008-01-12 06:09:53 EST
Created attachment 291457 [details]
log
Comment 3 Jim Meyering 2008-01-18 07:17:38 EST
Created attachment 292133 [details]
Xorg.0.log
Comment 4 Jim Meyering 2008-01-18 07:19:39 EST
Thanks!  rawhide now works for me using xorg-x11-drv-ati.x86_64
6.7.196-7.fc9, but only up to 1280x960 resolution DVI on my Dell 2001FP.
That monitor does 1600x1200 just fine with the closed-source nvidia driver,
and I'm motivated to make it work with an open source one.  Problems with
this monitor are not new, e.g., (patch for RV280 here)
http://suif.stanford.edu/~csapuntz/rv280-linux-dvi.html
so I'm optimistic.  Any hints?

With the attached conf, all I get on the monitor is this:

  2:DVI-D
  Can not display this mode

I've attached new Xorg log as comment #3, above.
Comment 5 Jim Meyering 2008-01-18 07:24:27 EST
Created attachment 292134 [details]
xorg.conf

Here's the xorg.conf mentioned in #4 above.
Comment 6 Dave Airlie 2008-03-26 19:32:56 EDT
does this still happen? the patch provided is a dirty hack but I'd like to try
and fix this correctly.
Comment 7 Jim Meyering 2008-03-28 05:40:57 EDT
Glad to hear you're interested!  I've just confirmed that it still happens, with
xorg-x11-drv-radeonhd-1.1.0-0.7.20080301git.fc9.x86_64
Comment 8 Dave Airlie 2008-03-30 19:58:41 EDT
oh I'm not talking about radeonhd, please try with -ati driver..

Comment 9 Jim Meyering 2008-03-31 04:03:49 EDT
The -ati driver gives the same result.
log attached
Comment 10 Jim Meyering 2008-03-31 04:05:42 EDT
Created attachment 299690 [details]
log using -ati driver and Dell 2001FP

this is with xorg-x11-drv-ati-6.8.0-7.fc9.x86_64
Comment 11 Jim Meyering 2008-04-02 14:31:43 EDT
Hi Dave,
Tried again, this time with xorg-x11-drv-ati-6.8.0-8.fc9.x86_64.
Same result :-(
Comment 12 Jim Meyering 2008-04-23 13:54:51 EDT
Created attachment 303531 [details]
new log, now w/Option "ModeDebug" "true"

Hi again,

At ajax's suggestion, I've retried with the latest from rawhide, and with
Option "ModeDebug" "true"
added to the Monitor section.  New log file below.
Comment 13 Jim Meyering 2008-05-16 06:38:53 EDT
Created attachment 305670 [details]
retried with same config as above

Hi, since I've seen new drivers come in to rawhide, I've retried.
Unfortunately, I still get black screen with the usual "can not display this
mode" message from the monitor.
Comment 14 Jim Meyering 2008-07-03 04:37:50 EDT
With the following config (from Dave Airlie), everything works fine using
today's rawhide.

Thanks again, Dave!

# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
	Option	    "XkbVariant" "intl"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	Option	     "dpms"
	VendorName   "Dell"
	ModelName    "Dell 2001FP (Digital)"
	Modeline    "1600x1200_RB" 130.25 1600 1648 1680 1760 1200 1203 1207 1235
	Modeline    "1600x1200" 160.96 1600 1704 1880 2160 1200 1201 1204 1242
	Option "PreferredMode" "1600x1200_RB"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "radeon"
	Option      "Monitor-DVI-0" "Monitor0"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Note You need to log in before you can comment on or make changes to this bug.