Bug 309461 - utrace: tkill(SIGCONT) is not reported by waitpid() under ptrace
Summary: utrace: tkill(SIGCONT) is not reported by waitpid() under ptrace
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: beta
: ---
Assignee: Roland McGrath
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords: Regression
Depends On: 248532
Blocks: 425461
TreeView+ depends on / blocked
 
Reported: 2007-09-27 18:00 UTC by Jan Kratochvil
Modified: 2008-05-21 14:56 UTC (History)
1 user (show)

Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 14:56:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testcase. (5.87 KB, text/plain)
2007-09-27 18:00 UTC, Jan Kratochvil
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0314 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5.2 2008-05-20 18:43:34 UTC

Description Jan Kratochvil 2007-09-27 18:00:19 UTC
+++ This bug was initially created as a clone of Bug #248532 +++

Description of problem:
Behavior change from the upstream.  It affects the method I found out as the
minimal/reliable way to attach unstopped+stopped processes on upstream kernels:
http://www.jankratochvil.net/priv/ver5.txt
* kill(SIGSTOP) the child
* waitid() (waitpid()) on it to catch its SIGSTOP notification
* PTRACE_ATTACH
* tkill(SIGCONT)
* waitpid() - should not hang

Version-Release number of selected component (if applicable):
kernel-2.6.18-48.el5.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. gcc -o attach-sigcont-wait attach-sigcont-wait.c -Wall -ggdb2
2. ./attach-sigcont-wait

Actual results:
Aborted
(due to a timeout on hung waitpid())

Expected results:
PASS

Comment 1 Jan Kratochvil 2007-09-27 18:00:19 UTC
Created attachment 208791 [details]
Testcase.

Comment 3 Jan Kratochvil 2007-11-16 23:43:34 UTC
Already fixed in the original Fedora Bug 248532.


Comment 4 Eric Bachalo 2007-12-14 20:36:47 UTC
Roland is/will be working on this issue.

Comment 5 RHEL Product and Program Management 2007-12-14 20:37:23 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 Don Zickus 2007-12-21 20:18:00 UTC
in 2.6.18-62.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 9 Mike Gahagan 2008-01-28 21:24:55 UTC
Confirmed attach-sigcont-wait now passes with the -75.el5 kernel

Comment 11 errata-xmlrpc 2008-05-21 14:56:33 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html



Note You need to log in before you can comment on or make changes to this bug.