Bug 30953 - fdisk / DiskDruid mis-handle large disks
fdisk / DiskDruid mis-handle large disks
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 11:00 EST by Al Grabauskas
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 18:23:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Al Grabauskas 2001-03-07 11:00:39 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.0-0.99.11 i686)


i was installing fisher in the second half of a 60G ide and could't create
a new partition for it due to "not enough free space", even though the disk
was just over 50% used.

DiskDruid and fdisk both exhibit this behavior. DD reported the disk (in
anaconda) as follows:

total 58643  geom (c/h/s) 7476/255/63 used 32247 free 26396

this is on a pogo linux althura - 1Ghz tbird, 256M, 60G ibm ata100 - specs
can be found on www.pogolinux.com

i reused an existing partition, and the install went fine (nice beta, btw)

if you want me to test an update for you under this configuration, and you
tell me where to get the relevant files/executables, i'll be happy to do
that.



Reproducible: Always
Steps to Reproduce:
1. run the install
2. choose to partition manually w/ either DD or fdisk

	

Actual Results:   see description of problem

Expected Results:   see description of problem
Comment 1 Glen Foster 2001-03-07 17:07:09 EST
We (Red Hat) should really try to fix this before next release.
Comment 2 Michael Fulbright 2001-03-07 18:26:39 EST
Brent please verify with a large disk (>64k cylinders logical) that recent trees
handle this correctly (disk druid and fdisk).
Comment 3 Brent Fox 2001-03-07 18:52:36 EST
Can you test with the Wolverine beta?  There was quite a bit of improvement
between Fisher and Wolverine.  I've got a feeling that this may have already
been fixed.
Comment 4 Michael Fulbright 2001-03-09 14:57:55 EST
abrown is going to test this.
Comment 5 Michael Fulbright 2001-03-09 18:23:55 EST
abrown confirmed this is fixed.

Note You need to log in before you can comment on or make changes to this bug.