Bug 309551 - utrace: SA_RESETHAND fails on 1st PTRACE_CONT(sig)
utrace: SA_RESETHAND fails on 1st PTRACE_CONT(sig)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
medium Severity medium
: beta
: ---
Assigned To: Roland McGrath
Martin Jenner
: Regression
: 364821 (view as bug list)
Depends On: 284311
Blocks: 425461
  Show dependency treegraph
 
Reported: 2007-09-27 14:18 EDT by Jan Kratochvil
Modified: 2010-10-22 15:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:56:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Testcase. (4.04 KB, text/plain)
2007-09-27 14:18 EDT, Jan Kratochvil
no flags Details

  None (edit)
Description Jan Kratochvil 2007-09-27 14:18:52 EDT
+++ This bug was initially created as a clone of Bug #284311 +++

Description of problem:
For the user-level impact see the Bug 284311.

If one signals the inferior during PTRACE_CONT and the inferior's handler is
using SA_RESETHAND then the signal will be delivered to the default handler (the
 installed one gets ignored).

Version-Release number of selected component (if applicable):
kernel-2.6.18-48.el5.x86_64

Steps to Reproduce:
1. gcc -o sa-resethand-on-cont-signal sa-resethand-on-cont-signal.c -Wall -ggdb2

Actual results:
FAIL

Expected results:
PASS
Comment 1 Jan Kratochvil 2007-09-27 14:18:52 EDT
Created attachment 208871 [details]
Testcase.
Comment 2 Mike Gahagan 2007-10-25 13:23:17 EDT
Confirmed the failure is reproduced in rhts with the 1017.0 tree
http://rhts.lab.boston.redhat.com/cgi-bin/rhts/jobs.cgi?id=9498&type=Single
Comment 3 Jan Kratochvil 2007-11-16 18:42:02 EST
Already fixed in the original Fedora Bug 284311.
Comment 4 Eric Bachalo 2007-12-14 15:37:40 EST
Roland is/will be working on this issue.
Comment 5 RHEL Product and Program Management 2007-12-14 15:45:53 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Roland McGrath 2007-12-17 17:43:12 EST
*** Bug 364821 has been marked as a duplicate of this bug. ***
Comment 8 Don Zickus 2007-12-21 15:18:02 EST
in 2.6.18-62.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 10 Mike Gahagan 2008-01-28 15:44:37 EST
Confirmed sa-resethand-on-cont-signal now passes when using the -75.el5 kernel
Comment 12 errata-xmlrpc 2008-05-21 10:56:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.