Bug 30977 - Installer didn't recognize RAID controller
Installer didn't recognize RAID controller
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 14:21 EST by Daniel Senie
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 21:26:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Senie 2001-03-07 14:21:01 EST
While the install kernel and the running kernel both contain a current 
version of the Mylex DAC960 driver from Dandelion/Mylex, the installer 
fails to recognize the signature of at least one of the newer cards. The 
card I tried was an AcceleRAID 170. The lspci -v output of relevance was:

03:05.1 RAID bus controller: Mylex Corporation: Unknown device 0050 (rev 
02)
        Subsystem: Mylex Corporation: Unknown device 0052
        Flags: bus master, fast Back2Back, medium devsel, latency 64, IRQ 
10
        Memory at fc000000 (32 bit, prefetchable) [size=8K]
        Expansion ROM at <unassigned> [disabled] [size=32K]
        Capabilities [80] Power Management version 2

The controllers which are recognized are no longer even manufactured! 
Please add the appropriate data so that this controller is recognized.

I can re-test this easily. I have a test machine set up for this purpose.
Comment 1 Glen Foster 2001-03-07 16:51:45 EST
Can you please run "lspci -n" and give us the output on this problem?  It'll
help diagnose it...
Comment 2 Glen Foster 2001-03-07 17:07:17 EST
We (Red Hat) should really try to fix this before next release.
Comment 3 Daniel Senie 2001-03-07 17:09:51 EST
Yes, fixing this before the next release would be MAJORLY appreciated. We rely 
heavily on being able to use the Mylex-based RAID arrays as our only disks on 
systems. Whatever I can do to accelerate that process (testing, etc.) I will do.

I'll get you the lspci -n info later today. Here I thought I was being good 
supplying the lspci -v before being asked!
Comment 4 Daniel Senie 2001-03-07 21:26:36 EST
I'm guessing you need the line matching the RAID card in the original bug 
report. So, here's the matching lspci -n info:

03:05.1 Class 0104: 1069:0050 (rev 02)

If you'd like the full lspci -n listing, let me know. I will save it (I have to 
hand-type it all).
Comment 5 Bill Nottingham 2001-03-07 22:29:32 EST
This is already fixed; the IDs got accidentally removed from the pcitable.
Comment 6 Daniel Senie 2001-03-07 22:37:09 EST
Good news indeed. Any chance of a re-spun disc 1 image so I can try it out? I 
have other things to test as well, and it'd sure help if I could do a full 
install. (or alternatively some documentation on how to effect the change and 
respin a CD).
Comment 7 Daniel Senie 2001-04-17 17:59:58 EDT
Good news is it was recognized. Bad news is it now locks the system up solid. 
Note that I suggested someone build a fixed version for me to test? I wish 
that'd happened, since the 7.1 disc images still can't be used to install on a 
Mylex AcceleRAID based system.

Note You need to log in before you can comment on or make changes to this bug.