Bug 30978 - [aic7xxx] device takes VERY long time in boot
[aic7xxx] device takes VERY long time in boot
Status: CLOSED DUPLICATE of bug 29555
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 14:24 EST by Daniel Senie
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-17 17:53:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Senie 2001-03-07 14:24:05 EST
In a test system with a two channel AIC-7896 controller on the motherboard 
(and difficult to disable), the insmod for the driver results in (viewable 
on VC4) scsi probes and errors to each possible target device number, and 
takes 5 to 10 minutes to complete this process. The buses contain nothing. 
If the're terminated, the same results are observed as if they're not 
terminated. Seems like the driver should be able to make a fairly quick 
determination that nobody's home.

Motherboard is Intel L440GX+ Lancewood. Easily reproducable here.
Comment 1 Glen Foster 2001-03-07 16:53:01 EST
This sounds more like a kernel issue than an installer issue.
Comment 2 Daniel Senie 2001-03-07 17:11:40 EST
I'll buy that. BTW, I also ran some test installs with RH 6.1 and 6.2, both of 
which took a while at the insmod of the AIC7xxx, but didn't spew on VC4 in the 
process. Not sure they took less time, or were just less verbose about it.
Comment 3 Michael K. Johnson 2001-03-12 22:20:39 EST
Could you install the latest kernels from rawhide and see if they
have the same behaviour?
Comment 4 Daniel Senie 2001-03-13 08:00:26 EST
Because this is happening during an install, I can't easily just load a new 
kernel and try it. What would work is either:

1. Create a new .iso of disc1 of the wolverine set. I can test for this bug, as 
well as verifying the fix on the Mylex AcceleRAID 170 issue.

2. Point me at some instructions for recreating the disc1 with these things 
applied. Note that this means replacing the boot kernel as well as the kernels 
to be installed. #1 is probably easier.

No problem at this end downloading an iso image and burning it for the tests.
Comment 5 R P Herrold 2001-03-13 22:20:09 EST
I had mixed results -- reasonable spinup and install without issue on a
NetServer 5/100 LH at home -- and totally failed on a NetServer 5/100 LC at the
office with kernel-2.4.2-0.1.23 from the 0309 build ... I will investigate the
failure further ...
Comment 6 Doug Ledford 2001-03-14 23:17:01 EST
I would need to know more about what error messages the boot kernel spewed about
the aic7xxx controllers in order to figure out what's going on.  Also, if there
is nothing connected, and changing termination didn't make a difference in the
output, then it might indicate something suspicious about the termination on the
motherboard.
Comment 7 R P Herrold 2001-03-14 23:27:12 EST
This host was also fighting geometry issues -- see:

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=31778

I have another SCSI drive to attach and report from ... 

Termination is non-powered at the end of the unidirectional chain, with
termination NOT enabled on the drive ... other end is the connector in the
onboard motherboard controller ...
Comment 8 Daniel Senie 2001-04-17 17:53:32 EDT
This bug is now applicable to RedHat 7.1. The released edition contains the 
same problem. If there's a AIC7xxx present, be prepared to wait 10 minutes 
while a scan is done on every non-existant device, and an error message 
generated on one of the alternate consoles.
Comment 9 Doug Ledford 2001-04-19 20:03:30 EDT
This sounds like a dup of 29555

*** This bug has been marked as a duplicate of 29555 ***

Note You need to log in before you can comment on or make changes to this bug.