Bug 30979 - /tmp/install mozilla-psm install error
Summary: /tmp/install mozilla-psm install error
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-07 19:24 UTC by Joshua Jensen
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 19:54:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2001-03-07 19:24:43 UTC
From an install of RC2 in /tmp/install.log:

Installing mozilla-psm.
execution of %post scriptlet from mozilla-psm-0.7-14 failed, exit status
127


Thanks,

Joshua Jensen

Comment 1 Christopher Blizzard 2001-03-07 19:35:38 UTC
Was it installed before the mozilla package was?  Jeff, didn't you fix this
ordering bug in rpm?  That -14 rpm is the most recent and uses Prereq: not
Requires: so it should be working.

Comment 2 Christopher Blizzard 2001-03-07 19:36:02 UTC
Also the same as 23466.  I'll mark it once Jeff answers.

Comment 3 Joshua Jensen 2001-03-07 20:58:07 UTC
Yes, the psm package was installed far before the other mozilla packages.

Comment 4 Christopher Blizzard 2001-03-07 22:06:39 UTC
Flinging over the fence to jbj since it's an rpm feature.

Comment 5 Jeff Johnson 2001-03-08 13:28:44 UTC
The order should be mozilla first, mozilla-psm, the ordering can be verified by
doing
	rpm -Uvv mozilla-psm* mozilla* --test
and looking for
	D: ========== tsorting packages
	D:     0 (1,1) mozilla-0.7-14
	D: ========== successors only (presentation order)
	D:     1 (1,2) mozilla-psm-0.7-14
Note that mozilla has been sorted before mozilla-psm even though the
packages were given in the opposite order.

Installing all mozilla packages works for me.


Comment 6 Joshua Jensen 2001-03-08 14:24:29 UTC
I'm not sure if you mean "fixed post-RC2" or not, but I can guarantee that in
RC2 mozilla-psm installs per /tmp/install.log on line 93, and the other two
mozilla packages install on line 200-and-something.  This fact along with the
mozilla-psm error in install.log indicates to me that there IS a problem, at
least in RC2.

Comment 7 Jeff Johnson 2001-03-08 14:42:48 UTC
I just checked with brock and confirmed that the problem is present RC2.
However,
there are 2 changes in rpm that I suspect have not filtered out yet that fix the
problem.

Reopening until brock confirms problem is fixed in RCn.

Comment 8 Jeff Johnson 2001-03-08 19:10:14 UTC
Verified as still present Right Now.

This is an anaconda issue, as anaconda has a precomputed package ordering these
days to avoid cdrom mount flip-flops, msw has gory details. Changing component.

Comment 9 Glen Foster 2001-03-09 23:28:36 UTC
This defect considered MUST-FIX (show-stopper) for Florence Gold

Comment 10 Matt Wilson 2001-03-12 19:54:47 UTC
Huh?  I just use the ordering that RPM gives me.  What version of RPM is
installed in the buildroot?  Seems to be 0.28.  Should I put 0.41 in there?


Comment 11 Matt Wilson 2001-03-12 20:27:58 UTC
I installed the latest RPM in the buildroot.  Here's the order around
mozilla-psm.

libtiff-3.5.5-9.i386.rpm
ImageMagick-5.2.7-2.i386.rpm
libxml-1.8.10-1.i386.rpm
lynx-2.8.4-9.i386.rpm
mozilla-0.7-14.i386.rpm
mozilla-mail-0.7-14.i386.rpm
mozilla-psm-0.7-14.i386.rpm
netpbm-progs-9.9-5.i386.rpm
imlib-1.9.8.1-2.i386.rpm
extace-1.4.4-2.i386.rpm
gnome-libs-1.2.8-10.i386.rpm




Note You need to log in before you can comment on or make changes to this bug.