Bug 30991 - --noddcprobe Segmentation fault
Summary: --noddcprobe Segmentation fault
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-07 20:30 UTC by Joshua Jensen
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-10 03:20:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joshua Jensen 2001-03-07 20:30:41 UTC
On my laptop, "Xconfigurator --noddcprobe" will segfault once I select
Generic LCD Laptop 1024x768 screen.  SuperProbe tells me that my video card
is an ATI Rage Mobility with 8megs, Xconfigurator tells me that the PCI
Entry is ATI|Rage Mobility P/M AGP 2x

Thanks,

Joshua Jensen

Comment 1 Bill Nottingham 2001-03-07 21:15:51 UTC
Does the current Xconfigurator in rawhide (4.9.16-1) display the same
behavior?

Comment 2 Joshua Jensen 2001-03-07 23:10:18 UTC
There seems to be no difference in the RC2 and Rawhide's Xconfigurator:

[joshua@joshua test]$ md5sum
rawhide-20010307/i386/RedHat/RPMS/Xconfigurator-4.9.16-1.i386.rpm
7.1-rc2/i386/RedHat/RPMS/Xconfigurator-4.9.16-1.i386.rpm 
52b845f36ad8b793f1ad478e5e76820b 
rawhide-20010307/i386/RedHat/RPMS/Xconfigurator-4.9.16-1.i386.rpm
52b845f36ad8b793f1ad478e5e76820b 
7.1-rc2/i386/RedHat/RPMS/Xconfigurator-4.9.16-1.i386.rpm


Joshua Jensen

Comment 3 Glen Foster 2001-03-08 22:55:46 UTC
This defect considered MUST-FIX (showstopper) for Florence Gold

Comment 4 Bill Nottingham 2001-03-09 16:58:07 UTC
What laptop model? Does the Xconfigurator at
http://people.redhat.com/notting/Xconfigurator/

fare any better?

Comment 5 Joshua Jensen 2001-03-09 21:37:03 UTC
Tried with the new Xconfigurator off of Bill's webpage, and I still find the
same segfault.  The laptop is the *exact* same thing as a Dell Inspiron 5000,
only it is a Sceptre 6900.  Made and assembled by the same company in Tiawan.

Joshua Jensen

Comment 6 Bill Nottingham 2001-03-10 00:46:52 UTC
If you build a debugging version can you get a backtrace?

Comment 7 Joshua Jensen 2001-03-10 03:20:35 UTC
I will try anything, just tell me what to do/try.

Comment 8 Preston Brown 2001-03-12 18:29:35 UTC
fixed in 4.9.20 and later.



Note You need to log in before you can comment on or make changes to this bug.