Bug 31013 - root booting into Gnome continually accesses floppy drive (/dev/fd0)
Summary: root booting into Gnome continually accesses floppy drive (/dev/fd0)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-07 21:55 UTC by bcling
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 19:37:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output (223.03 KB, text/plain)
2001-03-08 19:10 UTC, bcling
no flags Details
/etc/fstab (994 bytes, text/plain)
2001-03-08 19:11 UTC, bcling
no flags Details

Description bcling 2001-03-07 21:55:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22-1121 i686)


7.0.91 custom install.  As root, execute startx.  Floppy drive light
illuminates and stays on almost constantly.  This does NOT happen as a
non-root user.  Error messages follow: (this error occurs multiple times,
could not find any more descriptive error messages)


Reproducible: Always
Steps to Reproduce:
1. Install Red Hat Linux 7.0.91
2. Log on as root (either directly or su -)
3. startx
4. Normal users don't have this problem.
	

Actual Results:  Floppy light illuminates and drive access attempted.

Expected Results:  No light... ;-)  No access, unless specified.

Tested on three Intel systems (PII, PIII) with three different
motherboards.

Mar  7 09:28:10 localhost kernel: end_request: I/O error, dev 02:00
(floppy), sector 0
Mar  7 09:28:42 localhost last message repeated 16 times

Comment 1 bcling 2001-03-07 21:57:16 UTC
KDE doesn't have this problem.

Comment 2 Alexei Podtelezhnikov 2001-03-08 00:14:12 UTC
I can confirm. I saw this problem too. The only differences in my situation is
that I didn't startx but rather have it restarted automatically after killing X.
Not only did I see the light, but also heard the noises. This was on Athlon
system on MSI's K7pro motherboard.

Comment 3 David Mason 2001-03-08 15:01:12 UTC
owen - I can't reproduce... could it be a magic dev situation?

Comment 4 Owen Taylor 2001-03-08 16:32:10 UTC
It seems unlikely unlikely. Magicdev doesn't touch any drives 
unless the file system type is iso9660.

But a quick way to check this would be to 'killall magicdev'
and see if the drive light goes off.


Comment 5 bcling 2001-03-08 17:02:24 UTC
It is magicdev... confirmed with killall magicdev.

Did not notice the behavior on 7.0.90... but it may have been an oversight.

Comment 6 bcling 2001-03-08 17:32:13 UTC
The process is listed below:

magicdev --activate-goad-server GOAD:magicdev:19990913 --goad-fd 10

Comment 7 Owen Taylor 2001-03-08 17:33:57 UTC
Strange, strange.

Could you strace magicdev to see what it doing exactly. (That is,

 killall magicdev
 strace magicdev

And provide the part that keeps on repeating at the end.)

Could you also provide your fstab?

Thanks,
                                     Owen


Comment 8 bcling 2001-03-08 19:10:25 UTC
Created attachment 12124 [details]
strace output

Comment 9 bcling 2001-03-08 19:11:55 UTC
Created attachment 12125 [details]
/etc/fstab

Comment 10 bcling 2001-03-08 19:14:30 UTC
7.0.90 had magicdev-0.2.7-5, same as 7.0... so there were obviously no problems
there.
Regressing to the previous version from current version of 0.3.0-4 corrects this
problem.

Comment 11 Owen Taylor 2001-03-08 19:37:43 UTC
Though I can't think of what would have changed from 0.2.7 => 0.3.0 or 
0.3.0 => 0.3.5 in this respect; and I can't see how from the 
code this could ever have occurred (unless someone recompiled
it an enabled floppy support.... in the sources there is:

/* #define FLOPPY_SUPPORT 1 */ /* This keeps the drive light on constantly */

could you grab the current 0.3.5 and see if the same problem occurs there?

Thanks again,
                                  Owen

Comment 12 Preston Brown 2001-03-08 20:41:54 UTC
wolverine had cdroms and floppies listed as type "auto", and magicdev was
supporting that.  We have since reverted to iso9660 for cdroms and auto for
floppies, and have magicdev only supporting type iso9660.  Solved.

Comment 13 Owen Taylor 2001-03-08 21:05:36 UTC
OK, glad to know this is resolved. (It can be hard to try and handle bug
reports for a package hat you aren't on prospector for... I had
no idea this change was made, and it also didn't get into the 
repository for magicdev which is on cvs.gnome.org.)


Note You need to log in before you can comment on or make changes to this bug.