Bug 310171 - ketchup does not work in rawhide
ketchup does not work in rawhide
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ketchup (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Benjamin Krill
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 20:29 EDT by Rik van Riel
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 02:06:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik van Riel 2007-09-27 20:29:26 EDT
Description of problem:

Simply using ketchup seems to break things.

$ ketchup linux-2.6.23-rc7-mm1
None -> linux-2.6.23-rc7-mm1
Traceback (most recent call last):
  File "/usr/bin/ketchup", line 737, in <module>
    transform(a, b)
  File "/usr/bin/ketchup", line 496, in transform
    a = install_nearest(base(b))
  File "/usr/bin/ketchup", line 137, in base
    v = revbase(ver)
  File "/usr/bin/ketchup", line 134, in revbase
    return "%s.%s" % (tree(ver), rev(ver))
  File "/usr/bin/ketchup", line 106, in tree
    return float(re.match(r'(\d+\.\d+)', ver).group(1))
AttributeError: 'NoneType' object has no attribute 'group'

Version-Release number of selected component (if applicable):

ketchup-0.9.8-1.fc8
Comment 1 Benjamin Krill 2007-09-28 04:40:12 EDT
Without "linux-" it works. So you only have to use the 
kernel version. I have contacted upstream and provide
a patch for this issue.

Currently, I wait for response.
Comment 2 Rik van Riel 2007-09-28 09:58:47 EDT
Doh, I guess that was a user error then.
Comment 3 Benjamin Krill 2007-10-11 02:06:06 EDT
Not a bug, because of a user error.

Note You need to log in before you can comment on or make changes to this bug.