Bug 310191 - NetworkManager blocking connection
NetworkManager blocking connection
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 20:49 EDT by Carl Preddy
Modified: 2008-11-26 12:36 EST (History)
3 users (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-11-26 12:36:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl Preddy 2007-09-27 20:49:17 EDT
Description of problem:
Updates break network connections on both my systems, the other being an i386.
Colorless nm-applet (0.7.0) icon with a red not-slash appears in the
notification area after reboot. If left-clicked says "NetworkManager is not
running". Odd, since I never run Networkmanager daemon or applet on these
hardwired systems; it is not checked for start at any runlevel. Network will not
connect, but admin/network says eth0 is active. Workaround is to start and stop
the Networkmanager daemon, which clears the icon and restores connectivity for
the session. Reboot restores the block.

Version-Release number of selected component (if applicable):
nm-applet 0.7.0.
From yum.log on F8test2 x86_64
Sep 27 18:46:59 Updated: NetworkManager - 1:0.7.0-0.3.svn2886.fc8.x86_64
Sep 27 18:47:00 Updated: NetworkManager-glib - 1:0.7.0-0.3.svn2886.fc8.x86_64
Sep 27 18:47:01 Updated: NetworkManager - 1:0.7.0-0.3.svn2886.fc8.i386
Sep 27 18:47:02 Updated: NetworkManager-glib - 1:0.7.0-0.3.svn2886.fc8.i386
Sep 27 18:47:05 Updated: NetworkManager-gnome - 1:0.7.0-0.3.svn2886.fc8.x86_64
kernel 2.6.23-0.204.rc8.fc8 (arrived at the same time)

How reproducible:Totally

Additional info:
The following error appear many times in the .xsession-errors log
** (nm-applet:2267): WARNING **: Error in get_devices: The name
org.freedesktop.NetworkManager was not provided by any .service files

My instances are running under VMWare Server 1.0.4 on different hosts and are up
to date.
Comment 1 Jeremy Katz 2007-09-28 17:31:32 EDT
Does this still happen with 0.3.svn2907?  I'm not able to reproduce it here now
Comment 2 Carl Preddy 2007-09-28 20:26:09 EDT
Sorry but I don't know how to install this revision. Its still happening with
the one shown above except for the network block. For some reason it now comes
up with the network enabled, but I still get the nm-applet not-active icon.
Comment 3 Jeremy Katz 2007-09-28 20:47:05 EDT
I fixed the applet not-active icon earlier today upstream and I can't reproduce
the network block with upstream as well.  So going to put in MODIFIED and will
hopefully be getting a new build out for tomorrow's rawhide
Comment 4 Carl Preddy 2007-09-29 08:30:15 EDT
Looks like you got it Just received the 2914 build and the icon does not appear.
By the way, that's a rather lame icon. Looks more like a mouse to me.
Started NM daemon; applet appears and behaves as I imagine it should. If I stop
the daemon the applet is removed and the network is disconnected. Is this the
correct behavior? I then tried  "service network start". This does reconnect but
says "RTNETLINK answers: File Exists" nine times. I speculate that the link was
always active but blocked somewhere upstream. A "restart" would probably be better.
Comment 5 Alexei Podtelezhnikov 2007-10-01 21:46:11 EDT
2914 is blocking connections for me. 
I had to
service NetworkManager stop
before
service network restart
worked for me.
Comment 6 Alexei Podtelezhnikov 2007-10-02 09:47:40 EDT
I don't understand it. Something steals my WEP key and resets it to "off". 
Why can't I set it like this
iwconfig wlan0 key aaaaaaaaaa
and then follow up with
service network restart
which fails. When I check wat my key was, it was reset to off by the service 
command.
Comment 7 Dan Williams 2007-10-02 11:31:09 EDT
Alexei; if you want to control your wireless card directly with iwconfig, turn
NM off.  The two methods are incompatible with each other, and that's not a bug,
its intentional.
Comment 8 Bug Zapper 2008-11-26 02:52:05 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Jon Stanley 2008-11-26 12:36:42 EST
As this bug is in MODIFIED, Fedora believes that a fix has been committed that resolves the problem listed in this bug report.

If this is not the case, please re-open this report, noting the version of the package that you reproduced the bug against.

Thanks for the report!

Note You need to log in before you can comment on or make changes to this bug.