Bug 310241 - anaconda for upgrade won't assemble a half-full raid-1 array
anaconda for upgrade won't assemble a half-full raid-1 array
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 22:41 EDT by Bill Nottingham
Modified: 2014-03-16 23:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 23:22:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2007-09-27 22:41:03 EDT
Description of problem:

Unbeknownst to me, half of my two-drive raid-1 (a PV for a LVM array) was kicked
out a while back.

When I went to upgrade, anaconda failed after choosing the proper partition,
saying that it couldn't mount my LVM on /storage - upon investigation, it never
assembled the RAID correctly.

This may be intentional - in any case, after fixing the array, it upgraded fine.

Version-Release number of selected component (if applicable):

rawhide-20070927
Comment 1 Jeremy Katz 2007-09-27 23:22:36 EDT
We don't do partial array activation and haven't in general.  So this is the
right failure mode.  When we redo partitioning, we might look at partial arrays
again, but they still seem like a bad idea to me

Note You need to log in before you can comment on or make changes to this bug.