Bug 310341 - irq 16: nobody cared (try booting with the "irqpoll" option)
irq 16: nobody cared (try booting with the "irqpoll" option)
Status: CLOSED DUPLICATE of bug 246056
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-28 01:43 EDT by Sonal Santan
Modified: 2008-01-14 13:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 13:02:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sonal Santan 2007-09-28 01:43:38 EDT
Description of problem:
irq 16: nobody cared (try booting with the "irqpoll" option)

Call Trace:
 <IRQ>  [<ffffffff81063fa3>] __report_bad_irq+0x30/0x72
 [<ffffffff810641c8>] note_interrupt+0x1e3/0x227
 [<ffffffff81064ab4>] handle_fasteoi_irq+0xa9/0xd1
 [<ffffffff8100c080>] do_IRQ+0xf1/0x161
 [<ffffffff8100a071>] ret_from_intr+0x0/0xa
 <EOI>  [<ffffffff8115a717>] acpi_processor_idle+0x2a3/0x480
 [<ffffffff8115a70d>] acpi_processor_idle+0x299/0x480
 [<ffffffff8115a474>] acpi_processor_idle+0x0/0x480
 [<ffffffff81008e55>] cpu_idle+0x8c/0xaf

handlers:
[<ffffffff8842804b>] (i915_driver_irq_handler+0x0/0x127 [i915])
Disabling IRQ #16


Version-Release number of selected component (if applicable):
kernel-2.6.22.7-85.fc7
Linux lemon 2.6.22.7-85.fc7 #1 SMP Fri Sep 21 19:59:51 EDT 2007 x86_64 x86_64
x86_64 GNU/Linux
How reproducible:
A few minutes after every boot

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
lspci -v
00:00.0 Host bridge: Intel Corporation Mobile Memory Controller Hub (rev 03)
        Subsystem: Fujitsu Limited. Unknown device 13f2
        Flags: bus master, fast devsel, latency 0
        Capabilities: <access denied>

00:02.0 VGA compatible controller: Intel Corporation Mobile Integrated Graphics
Controller (rev 03) (prog-if 00 [VGA])
        Subsystem: Fujitsu Limited. Unknown device 13f4
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at fe000000 (64-bit, non-prefetchable) [size=1M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at 1800 [size=8]
        Capabilities: <access denied>

00:02.1 Display controller: Intel Corporation Mobile Integrated Graphics
Controller (rev 03)
        Subsystem: Fujitsu Limited. Unknown device 13f4
        Flags: bus master, fast devsel, latency 0
        Memory at fe100000 (64-bit, non-prefetchable) [size=1M]
        Capabilities: <access denied>

00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Contoller #4 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Fujitsu Limited. Unknown device 1414
        Flags: bus master, medium devsel, latency 0, IRQ 22
        I/O ports at 1820 [size=32]

00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #5 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Fujitsu Limited. Unknown device 1414
        Flags: bus master, medium devsel, latency 0, IRQ 22
        I/O ports at 1840 [size=32]

00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #2 (rev 03) (prog-if 20 [EHCI])
        Subsystem: Fujitsu Limited. Unknown device 1415
        Flags: bus master, medium devsel, latency 0, IRQ 23
        Memory at fe704800 (32-bit, non-prefetchable) [size=1K]
        Capabilities: <access denied>

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller
(rev 03)
        Subsystem: Fujitsu Limited. Unknown device 142d
        Flags: bus master, fast devsel, latency 0, IRQ 21
        Memory at fe700000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>

00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1
(rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=04, subordinate=07, sec-latency=0
        I/O behind bridge: 00002000-00002fff
        Memory behind bridge: fe200000-fe2fffff
        Prefetchable memory behind bridge: 000000008c000000-000000008c0fffff
        Capabilities: <access denied>

00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3
(rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=0c, subordinate=13, sec-latency=0
        Capabilities: <access denied>

00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4
(rev 03) (prog-if 00 [Normal decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=14, subordinate=17, sec-latency=0
        Memory behind bridge: fe300000-fe3fffff
        Capabilities: <access denied>

00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #1 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Fujitsu Limited. Unknown device 1414
        Flags: bus master, medium devsel, latency 0, IRQ 22
        I/O ports at 1860 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #2 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Fujitsu Limited. Unknown device 1414
        Flags: bus master, medium devsel, latency 0, IRQ 22
        I/O ports at 1880 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI
Controller #3 (rev 03) (prog-if 00 [UHCI])
        Subsystem: Fujitsu Limited. Unknown device 1414
        Flags: bus master, medium devsel, latency 0, IRQ 22
        I/O ports at 18a0 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI
Controller #1 (rev 03) (prog-if 20 [EHCI])
        Subsystem: Fujitsu Limited. Unknown device 1415
        Flags: bus master, medium devsel, latency 0, IRQ 23
        Memory at fe704c00 (32-bit, non-prefetchable) [size=1K]
        Capabilities: <access denied>

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3) (prog-if
01 [Subtractive decode])
        Flags: bus master, fast devsel, latency 0
        Bus: primary=00, secondary=1c, subordinate=20, sec-latency=32
        I/O behind bridge: 00003000-00003fff
        Memory behind bridge: fe400000-fe4fffff
        Prefetchable memory behind bridge: 0000000088000000-000000008bffffff
        Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation Mobile LPC Interface Controller (rev 03)
        Subsystem: Fujitsu Limited. Unknown device 140e
        Flags: bus master, medium devsel, latency 0
        Capabilities: <access denied>

00:1f.1 IDE interface: Intel Corporation Mobile IDE Controller (rev 03) (prog-if
8a [Master SecP PriP])
        Subsystem: Fujitsu Limited. Unknown device 140f
        Flags: bus master, medium devsel, latency 0, IRQ 20
        I/O ports at 01f0 [size=8]
        I/O ports at 03f4 [size=1]
        I/O ports at 0170 [size=8]
        I/O ports at 0374 [size=1]
        I/O ports at 1810 [size=16]

00:1f.2 SATA controller: Intel Corporation Mobile SATA AHCI Controller (rev 03)
(prog-if 01 [AHCI 1.0])
        Subsystem: Fujitsu Limited. Unknown device 1411
        Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 2300
        I/O ports at 1c00 [size=8]
        I/O ports at 18d4 [size=4]
        I/O ports at 18d8 [size=8]
        I/O ports at 18d0 [size=4]
        I/O ports at 18e0 [size=32]
        Memory at fe704000 (32-bit, non-prefetchable) [size=2K]
        Capabilities: <access denied>

00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
        Subsystem: Fujitsu Limited. Unknown device 1413
        Flags: medium devsel, IRQ 21
        Memory at 8c100000 (32-bit, non-prefetchable) [size=256]
        I/O ports at 1c20 [size=32]

04:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit
Ethernet Controller (rev 12)
        Subsystem: Fujitsu Limited. Unknown device 139a
        Flags: bus master, fast devsel, latency 0, IRQ 2299
        Memory at fe200000 (64-bit, non-prefetchable) [size=16K]
        I/O ports at 2000 [size=256]
        [virtual] Expansion ROM at 8c000000 [disabled] [size=128K]
        Capabilities: <access denied>

14:00.0 Network controller: Intel Corporation Unknown device 4229 (rev 61)
        Subsystem: Intel Corporation Unknown device 1100
        Flags: bus master, fast devsel, latency 0, IRQ 2298
        Memory at fe300000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: <access denied>

1c:03.0 CardBus bridge: O2 Micro, Inc. Unknown device 7136 (rev 01)
        Subsystem: Fujitsu Limited. Unknown device 13c6
        Flags: bus master, stepping, slow devsel, latency 168, IRQ 17
        Memory at fe403000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=1c, secondary=1d, subordinate=20, sec-latency=176
        Memory window 0: 88000000-8bfff000 (prefetchable)
        Memory window 1: 90000000-93fff000
        I/O window 0: 00003000-000030ff
        I/O window 1: 00003400-000034ff
        16-bit legacy interface ports at 0001

1c:03.2 Generic system peripheral [0805]: O2 Micro, Inc. Integrated MMC/SD
Controller (rev 02) (prog-if 01)
        Subsystem: Fujitsu Limited. Unknown device 13c6
        Flags: bus master, slow devsel, latency 32, IRQ 17
        Memory at fe402800 (32-bit, non-prefetchable) [size=256]
        Capabilities: <access denied>

1c:03.3 Mass storage controller: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)
        Subsystem: Fujitsu Limited. Unknown device 13c6
        Flags: slow devsel, IRQ 11
        Memory at fe400000 (32-bit, non-prefetchable) [size=4K]
        Capabilities: <access denied>

1c:03.4 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
(prog-if 10 [OHCI])
        Subsystem: Fujitsu Limited. Unknown device 13c6
        Flags: bus master, medium devsel, latency 32, IRQ 17
        Memory at fe401000 (32-bit, non-prefetchable) [size=4K]
        Memory at fe402000 (32-bit, non-prefetchable) [size=2K]
        Capabilities: <access denied>

cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 Duo CPU     T7100  @ 1.80GHz
stepping        : 13
cpu MHz         : 800.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 0
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc
pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 3594.13
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

processor       : 1
vendor_id       : GenuineIntel
cpu family      : 6
model           : 15
model name      : Intel(R) Core(TM)2 Duo CPU     T7100  @ 1.80GHz
stepping        : 13
cpu MHz         : 800.000
cache size      : 2048 KB
physical id     : 0
siblings        : 2
core id         : 1
cpu cores       : 2
fpu             : yes
fpu_exception   : yes
cpuid level     : 10
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov
pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc
pni monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr lahf_lm
bogomips        : 3590.99
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:


Laptop: Fujitsu Lifebook A series
Comment 1 Christopher Brown 2008-01-14 13:02:08 EST

*** This bug has been marked as a duplicate of 246056 ***

Note You need to log in before you can comment on or make changes to this bug.