This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 31042 - installer hangs hard after selecting the package media (e.g. CD-ROM or local hard-drive)
installer hangs hard after selecting the package media (e.g. CD-ROM or local ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Doug Ledford
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 22:48 EST by moo kim
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-09 11:12:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description moo kim 2001-03-07 22:48:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.74 [en] (WinNT; U)


Attempting to upgrade from 6.2 to 7.0, can't get the installer to work, but consistently hangs after
the package media is selected (local CD-ROM or local hard-drive).  I tried with various scsi drivers
of aic7xxx (i386/i586/i686) from http://people.redhat.com/dledford, but consistently fails with the
same hang problem.   I did not have this problem when RedHat 6.2 was fresh installed on 200 
MHz Pentium PC.   I copied the CDROM 1 and 2 to the local hard-drive, but it fails with same
failure.   Can someone please help ??

Reproducible: Always
Steps to Reproduce:
1. Boot the PC with boot disk.
2. Enter "text" from boot: prompt.
3. After English and US is selected, select CD-ROM on the package media.
4. Then it hangs with blank screen.   It does not respond with any key stokes.
	

Output from cat /proc/pci command
==========================
PCI devices found:
  Bus  0, device   0, function  0:
    Host bridge: Intel 82439HX Triton II (rev 3).
      Medium devsel.  Master Capable.  Latency=24.
  Bus  0, device   7, function  0:
    ISA bridge: Intel 82371SB PIIX3 ISA (rev 1).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  No bursts.
  Bus  0, device   7, function  1:
    IDE interface: Intel 82371SB PIIX3 IDE (rev 0).
      Medium devsel.  Fast back-to-back capable.  Master Capable.  Latency=16.
      I/O at 0xffa0 [0xffa1].
  Bus  0, device   8, function  0:
    VGA compatible controller: S3 Inc. Trio32/Trio64 (rev 68).
      Medium devsel.
      Non-prefetchable 32 bit memory at 0xf8000000 [0xf8000000].
  Bus  0, device  11, function  0:
    SCSI storage controller: Adaptec AIC-7881U (rev 0).
      Medium devsel.  Fast back-to-back capable.  IRQ 11.  Master Capable.  Latency=24.  Min Gnt=8.Max Lat=8.
      I/O at 0xfc00 [0xfc01].
      Non-prefetchable 32 bit memory at 0xffbef000 [0xffbef000].
  Bus  0, device  17, function  0:
    Ethernet controller: DEC DC21041 (rev 17).
      Medium devsel.  Fast back-to-back capable.  IRQ 10.  Master Capable.  Latency=24.
      I/O at 0xf880 [0xf881].
      Non-prefetchable 32 bit memory at 0xfff7fc00 [0xfff7fc00].

Output from "cat /proc/scsi/aic7xxx/0" command
====================================

Adaptec AIC7xxx driver version: 5.1.30/3.2.4
Compile Options:
  TCQ Enabled By Default : Disabled
  AIC7XXX_PROC_STATS     : Enabled
  AIC7XXX_RESET_DELAY    : 5

Adapter Configuration:
           SCSI Adapter: Adaptec AHA-294X Ultra SCSI host adapter
                           Ultra Narrow Controller at PCI 0/11/0
    PCI MMAPed I/O Base: 0xffbef000
 Adapter SEEPROM Config: SEEPROM found and used.
      Adaptec SCSI BIOS: Enabled
                    IRQ: 11
                   SCBs: Active 0, Max Active 3,
                         Allocated 15, HW 16, Page 255
             Interrupts: 37251
      BIOS Control Word: 0x10b6
   Adapter Control Word: 0x001d
   Extended Translation: Enabled
Disconnect Enable Flags: 0x00ff
     Ultra Enable Flags: 0x0000
 Tag Queue Enable Flags: 0x0000
Ordered Queue Tag Flags: 0x0000
Default Tag Queue Depth: 8
    Tagged Queue By Device array for aic7xxx host instance 0:
      {255,255,255,255,255,255,255,255,255,255,255,255,255,255,255,255}
    Actual queue depth per device for aic7xxx host instance 0:
      {1,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1}

Statistics:

(scsi0:0:0:0)
  Device using Narrow/Sync transfers at 10.0 MByte/sec, offset 15
  Transinfo settings: current(25/15/0/0), goal(25/15/0/0), user(25/15/0/0)
  Total transfers 5739 (3544 reads and 2195 writes)
             < 2K      2K+     4K+     8K+    16K+    32K+    64K+   128K+
   Reads:      14       0    1878     587     600     192     273       0
  Writes:       4       0    1964     212      14       1       0       0


(scsi0:0:5:0)
  Device using Narrow/Sync transfers at 10.0 MByte/sec, offset 15
  Transinfo settings: current(25/15/0/0), goal(25/15/0/0), user(25/15/0/0)
  Total transfers 0 (0 reads and 0 writes)
             < 2K      2K+     4K+     8K+    16K+    32K+    64K+   128K+
   Reads:       0       0       0       0       0       0       0       0
  Writes:       0       0       0       0       0       0       0       0


(scsi0:0:6:0)
  Device using Narrow/Sync transfers at 5.0 MByte/sec, offset 15
  Transinfo settings: current(50/15/0/0), goal(25/15/0/0), user(25/15/0/0)
  Total transfers 0 (0 reads and 0 writes)
             < 2K      2K+     4K+     8K+    16K+    32K+    64K+   128K+
   Reads:       0       0       0       0       0       0       0       0
  Writes:       0       0       0       0       0       0       0       0


Below is the boot message running 6.2 linux from hard-drive
===========================================:

Linux version 2.2.16-4 (root@porky.devel.redhat.com) (gcc version egcs-2.91.66 1
9990314/Linux (egcs-1.1.2 release)) #1 Tue Jun 20 19:22:15 EDT 2000
Detected 199432 kHz processor.
Console: colour VGA+ 80x25
Calibrating delay loop... 398.13 BogoMIPS
Memory: 127428k/131072k available (1036k kernel code, 416k reserved, 1700k data,
 64k init, 0k bigmem)
Dentry hash table entries: 262144 (order 9, 2048k)
Buffer cache hash table entries: 131072 (order 7, 512k)
Page cache hash table entries: 32768 (order 5, 128k)
VFS: Diskquotas version dquot_6.4.0 initialized
CPU: Intel Pentium 75 - 200 stepping 0c
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
Intel Pentium with F0 0F bug - workaround enabled.
POSIX conformance testing by UNIFIX
PCI: PCI BIOS revision 2.10 entry at 0xfda11
PCI: Using configuration type 1
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP, IGMP
TCP: Hash tables configured (ehash 131072 bhash 65536)
Initializing RT netlink socket
Starting kswapd v 1.5
Detected PS/2 Mouse Port.
Serial driver version 4.27 with MANY_PORTS MULTIPORT SHARE_IRQ enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A
pty: 256 Unix98 ptys configured
apm: BIOS version 1.2 Flags 0x03 (Driver version 1.13)
Real Time Clock Driver v1.09
RAM disk driver initialized:  16 RAM disks of 4096K size
PIIX3: IDE controller on PCI bus 00 dev 39
PIIX3: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:pio, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
md driver 0.90.0 MAX_MD_DEVS=256, MAX_REAL=12
raid5: measuring checksumming speed
   8regs     :   168.021 MB/sec
   32regs    :   123.063 MB/sec
using fastest function: 8regs (168.021 MB/sec)
scsi : 0 hosts.
scsi : detected total.
md.c: sizeof(mdp_super_t) = 4096
Partition check:
RAMDISK: Compressed image found at block 0
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem).
(scsi0) <Adaptec AHA-294X Ultra SCSI host adapter> found at PCI 0/11/0
(scsi0) Narrow Channel, SCSI ID=7, 16/255 SCBs
(scsi0) Cables present (Int-50 YES, Ext-50 NO)
(scsi0) Downloading sequencer code... 422 instructions downloaded
scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.1.30/3.2.4
       <Adaptec AHA-294X Ultra SCSI host adapter>
scsi : 1 host.
(scsi0:0:0:0) Synchronous at 10.0 Mbyte/sec, offset 15.
  Vendor: SEAGATE   Model: ST39175LW         Rev: 0001
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
(scsi0:0:1:0) Synchronous at 10.0 Mbyte/sec, offset 15.
  Vendor: SEAGATE   Model: ST32171N          Rev: 0280
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 1, lun 0
(scsi0:0:2:0) Synchronous at 10.0 Mbyte/sec, offset 15.
  Vendor: SEAGATE   Model: ST15150N          Rev: 4611
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdc at scsi0, channel 0, id 2, lun 0
(scsi0:0:5:0) Synchronous at 10.0 Mbyte/sec, offset 15.
  Vendor: MATSHITA  Model: CD-ROM CR-506     Rev: IG05
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 5, lun 0
(scsi0:0:6:0) Synchronous at 5.0 Mbyte/sec, offset 15.
  Vendor: CONNER    Model: CTT8000-S         Rev: 1.17
  Type:   Sequential-Access                  ANSI SCSI revision: 02
Uniform CD-ROM driver Revision: 3.10
SCSI device sda: hdwr sector= 512 bytes. Sectors= 17783240 [8683 MB] [8.7 GB]
 sda: sda1 sda2 < sda5 sda6 >
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 4222640 [2061 MB] [2.1 GB]
 sdb: sdb1
SCSI device sdc: hdwr sector= 512 bytes. Sectors= 8388315 [4095 MB] [4.1 GB]
 sdc: sdc1
autodetecting RAID arrays
autorun ...
... autorun DONE.
VFS: Mounted root (ext2 filesystem) readonly.
change_root: old root has d_count=1
Trying to unmount old root ... okay
Freeing unused kernel memory: 64k freed
Adding Swap: 618460k swap-space (priority -1)
st: bufsize 32768, wrt 30720, max buffers 5, s/g segs 16.
Detected scsi tape st0 at scsi0, channel 0, id 6, lun 0
tulip.c:v0.91g-ppc 7/16/99 becker@cesdis.gsfc.nasa.gov
eth0: Digital DC21041 Tulip rev 17 at 0xf880, 00:00:C0:48:5E:F4, IRQ 10.
eth0: 21041 Media table, default media 0800 (Autosense).
eth0:  21041 media #0, 10baseT.
eth0:  21041 media #4, 10baseT-FD.
eth0:  21041 media #1, 10base2.
eth0:  21041 media #2, AUI.
eth0: 21143 10baseT link beat good.
eth0: 21143 10baseT link beat good.
Comment 1 Michael Fulbright 2001-03-08 11:56:38 EST
Appears to be a kernel related issue with the aic driver.
Comment 2 moo kim 2001-03-08 15:55:48 EST
 One thing that I did not mention from the description was that I also tried to aic7xxx img from
 http://people.freebsd.org/~gibbs/linux/linux-aic7xxx-latest-rh70-driver-disk.img-i386 suggested
 by RedHat installation service personnel.   The problem with this img is that I was not able
 to copy the driver image into the floppy disk drive because the file is greater than the floppy
 can take.

 1,474,562 : linux-aic7xxx-latest-rh70-driver-disk.img

 The file size should be 1,474,560 instead of 1,474,562.

 I do not know whether driver img between http://people/redhat.com/dledford and ~gibbs/linux
 are supposed to be identical or not.   I do wish there is a HOW-TO that describes the steps
 for one to download the source, compile, and create the driver disk img so I can try it out.


 
Comment 3 Doug Ledford 2001-03-14 23:20:41 EST
Did you try not using any driver disks?  Also, when the system hangs, what is
happening with the SCSI bus?  Are there any kernel messages on VT3 or VT4 (I
can't remember which one the kernel messages go to)?
Comment 4 Alan Cox 2003-06-09 11:12:38 EDT
No reply in 2 years closing

Note You need to log in before you can comment on or make changes to this bug.