Bug 31043 - rpm-4.0.2-0.40.i386.rpm fails
Summary: rpm-4.0.2-0.40.i386.rpm fails
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-08 04:14 UTC by sean
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 04:14:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sean 2001-03-08 04:14:07 UTC
when I rpm -Fvvh the rpm  it fails at:

......
D:running preinstall script (if any)
+  '[' -f /var/lib/rpm/Packages -a -f   /var/lib/rpm/packages.rpm ']'
+  exit 1
execution of rpm-4.0.2-0.40 script failed, exit status 1
........

Both Packages and packages.rpm exist in /var/lib/rpm.

I'm using rpm-3.0.4-0.48, glibc -2.2-12 and db1-1.85. db2-2.4.14-5,
db3-3.1.17-5.

Comment 1 Jeff Johnson 2001-03-08 13:38:48 UTC
You need to remove one of packages.rpm or Packages, as you have both
a db1 and a db3 database present. on your system.

The smaller of the two is probably the one that needs to be nuked. If you
are using rpm-3.0.4, you should be using packages.rpm. Try doing
	cd /var/lib/rpm
	mv Packages Packages-SAVE
and install rpm. If the output of "rpm -qa" appears satisfactory, then remove
the file Packages-SAVE.

Finally, after upgrading, you should do "rpm --rebuilddb" to convert the
database
to db3 format.

Comment 2 sean 2001-03-09 02:19:05 UTC
FWIW, I mv'd Packages, which was the smaller file.  That  didn't work. rpm
thought I had nothng installed., e.g. glibc, bash,etc.
I then mv'd packages.rpm ,and put Packages back.  That worked.

This may be because I rpm --rebuilddb in rpm-3 after I installed db3.

In any case it works now. thanks for your help.

jay


Note You need to log in before you can comment on or make changes to this bug.