Bug 31043 - rpm-4.0.2-0.40.i386.rpm fails
rpm-4.0.2-0.40.i386.rpm fails
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 23:14 EST by sean
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 23:14:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2001-03-07 23:14:07 EST
when I rpm -Fvvh the rpm  it fails at:

......
D:running preinstall script (if any)
+  '[' -f /var/lib/rpm/Packages -a -f   /var/lib/rpm/packages.rpm ']'
+  exit 1
execution of rpm-4.0.2-0.40 script failed, exit status 1
........

Both Packages and packages.rpm exist in /var/lib/rpm.

I'm using rpm-3.0.4-0.48, glibc -2.2-12 and db1-1.85. db2-2.4.14-5,
db3-3.1.17-5.
Comment 1 Jeff Johnson 2001-03-08 08:38:48 EST
You need to remove one of packages.rpm or Packages, as you have both
a db1 and a db3 database present. on your system.

The smaller of the two is probably the one that needs to be nuked. If you
are using rpm-3.0.4, you should be using packages.rpm. Try doing
	cd /var/lib/rpm
	mv Packages Packages-SAVE
and install rpm. If the output of "rpm -qa" appears satisfactory, then remove
the file Packages-SAVE.

Finally, after upgrading, you should do "rpm --rebuilddb" to convert the
database
to db3 format.
Comment 2 sean 2001-03-08 21:19:05 EST
FWIW, I mv'd Packages, which was the smaller file.  That  didn't work. rpm
thought I had nothng installed., e.g. glibc, bash,etc.
I then mv'd packages.rpm ,and put Packages back.  That worked.

This may be because I rpm --rebuilddb in rpm-3 after I installed db3.

In any case it works now. thanks for your help.

jay

Note You need to log in before you can comment on or make changes to this bug.