Bug 31061 - after running SVGATextMode startx fails
after running SVGATextMode startx fails
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: SVGATextMode (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Helge Deller
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-08 06:30 EST by Mick Mearns
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 06:30:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mick Mearns 2001-03-08 06:30:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


if SVGATextmode is invoked with or without a mode, running 'startx' later 
on fails. On one system the KDE desktop gate painted properly but the 
mouse leaves boxes behind and no clicks work, the display starts to flash 
in large 1" suare boxes. On the other it never got past the grey-checked 
pre-KDE screen. Had to hard reset.
rpm -q SVGATextMode : SVGATextMode-1.9-7
The system that goes crazy is using a Matrox Mystique 4Meg Frame Buffer 
device, the other is using a ATI Pro Turbo 64 2Meg

This happens in 2.2.16-22, 2.2.18, 2.4.2 and 2.4.2-ac10-fixed

Commenting out the line I had in .bashrc fixed it on both systems.

Reproducible: Always
Steps to Reproduce:
1.SVGATextmode
2.startx
3.
	

Actual Results:  blinking blocks, or grey screen forever

Expected Results:  KDE
Comment 1 Helge Deller 2001-03-19 09:12:27 EST
SVGATextMode should never be used together with framebuffer-devices.
Since both of your cards are supported by framebuffer-drivers can't you use
fbset and setfont/consolechars instead ?

btw, SVGATextMode will no longer be part of the next RedHat Linux release (>7).

Note You need to log in before you can comment on or make changes to this bug.