Bug 31072 - configuration option for MS Intellimouse Explorer
Summary: configuration option for MS Intellimouse Explorer
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-08 16:27 UTC by jbowman
Modified: 2008-08-01 16:22 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 21:31:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jbowman 2001-03-08 16:27:00 UTC
Could we get the Intellimouse Explorer as an entry in the mouse
configuration screen? It is a 5-button+wheel mouse that using the exact
same protocol as the standard Intellimouse, however it requires a slightly
different configuration in XF86Config to have the additional buttons
working properly.

Inside XF86Config:
Option "Buttons" "7"
Options "ZAxisMapping" "6 7"

is needed, followed by:
xmodmap -e "pointer = 1 2 3 6 7 4 5"
when X starts up in order to map the buttons on the wheel correctly.

Comment 1 Trond Eivind Glomsrxd 2001-03-08 16:58:35 UTC
The xmodmap thing isn't going to happen now. If you don't specify 7 buttons,
what buttons does the wheel map into?

Comment 2 jbowman 2001-03-08 18:12:58 UTC
The xmodmap is necessary to get the scroll wheel working properly. If you leave
off the xmodmap in the configuration I listed, the side buttons of the mouse
scroll and the wheel mouse triggers button events 4 and 5.  If you instead do
ZAxisMapping 4 5, the scroll wheel works but X will not see the remaining two
buttons, even with "Buttons 7" specified. It looks like X is chopping off any
buttons after the ZAxisMapped ones.

I

Comment 3 Trond Eivind Glomsrxd 2001-03-08 20:45:12 UTC
I'll add the name, but you won't get the last two buttons - not that any apps
would have recognized them anyway.

Comment 4 Trond Eivind Glomsrxd 2001-03-08 21:25:15 UTC
USB and/or PS/2?

Comment 5 jbowman 2001-03-08 21:31:02 UTC
I _believe_ this works for both PS/2 and USB. However, the rest of the mouse
configuration options are different between the PS/2 and the USB. I'll
double-check this evening to make sure this works for USB as well, but I know it
works for certain with PS/2.

Comment 6 Trond Eivind Glomsrxd 2001-03-08 21:32:55 UTC
On further thought: If they just choose the generic Intellimouse (which would be
the obvious thing to do), it would work just fine.

Comment 7 jbowman 2001-03-09 01:51:36 UTC
Yes, it works just fine with the standard intellimouse select, you just can't
access the extra buttons (which was what I was after here).  If not for 7.1,
could we perhaps get this for a future release?

Comment 8 Stefan Furtmayr 2001-09-01 16:15:55 UTC
Besides the already mentioned options including Xmodmap 
the "Protocol" "ExplorerPS2" is necessary for my MS Intellimouse Optical to get 
all seven buttons to work.
This can be tested with xev or Mozilla.

See also:

Mozilla: http://bugzilla.mozilla.org/show_bug.cgi?id=30431
Galeon:  http://bugzilla.gnome.org/show_bug.cgi?id=59532



Note You need to log in before you can comment on or make changes to this bug.