Bug 310991 - TB8f5a3431 yumRepo.py:749:_getRepoXML:RepoError: Cannot retrieve repository metadata (repomd.xml) for repository: fedora. Please verify its path and try again
TB8f5a3431 yumRepo.py:749:_getRepoXML:RepoError: Cannot retrieve repository m...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-28 10:01 EDT by Lee Landrum
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 13:07:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Crash dump on pirut trying to update through auto update (2.12 KB, application/octet-stream)
2007-09-28 10:01 EDT, Lee Landrum
no flags Details

  None (edit)
Description Lee Landrum 2007-09-28 10:01:33 EDT
Description of problem:
Trying to update new install of Fedora and I got this crash reported as a
possible bug.

Version-Release number of selected component (if applicable):
Python 2.5

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Lee Landrum 2007-09-28 10:01:33 EDT
Created attachment 210421 [details]
Crash dump on pirut trying to update through auto update
Comment 2 Jeremy Katz 2007-10-01 17:08:28 EDT
Is this always reproducible?
Comment 3 mario 2007-10-10 05:04:24 EDT
I am suffering exactly the same
mario
Comment 4 mario 2007-10-11 12:55:12 EDT
Forget,
i got /etc/yum.conf  modified somehow by an added line
proxy=ftp://<user>@10.0.1.1:4480/.
By commenting out the line, everything works fine.

Thanks anyway
mario
Comment 5 Alik Elzin 2007-10-25 18:25:42 EDT
I installed about a week ago Fedora 7, but didn't have the time to look at it
until now, except for a first time update that took a very long time...

I got exactly the same problem (The attached equals exactly to the one i got).
My scenario though, was different.

I didn't do anything except adding stuff to the upper panel and creating a user
for my wife, specifically, did not change any file manually.

What i know that did happen is that i did not have a connection to the internet,
while the software updater was trying to find software to update.

Regardless of the problem, the reason i had connection problem is not because of
fedora installation - it is because my internet supplier logged me out.

I will try to relogin, now that the internet connection is up again, and see if
the problem recur.

I suggest to reopen the bug because i don't think i did something dangerous and
the problem happened.
Comment 6 Alik Elzin 2007-10-25 18:47:40 EDT
Now that the connection is up and running, i did a restart and still get the
same problem.

Perhaps the problem does not relate to an internet connection problem.

What i do know is that now the updater does not work any longer - even the
command 'yum update' doesn't work.

Perhaps because of the internet connection problem, some file that directs to a
url was changed - its inner urls delete ?
Comment 7 Alik Elzin 2007-10-25 19:51:55 EDT
Found a good forum thread regarding this issue.
I followed the answer of 'marko' and it fixed the yum execution.
The question is whether the referred files were updated somehow, and if so by whom ?
The fact is that the first update succeeded...
Comment 8 Alik Elzin 2007-10-25 19:52:40 EDT
Sorry, here is the forum's url:
http://forums.fedoraforum.org/forum/showthread.php?t=169831

Note You need to log in before you can comment on or make changes to this bug.