Bug 31111 - Logitech Wheel Mouse PS/2 USB
Summary: Logitech Wheel Mouse PS/2 USB
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-08 23:03 UTC by Craig Kelley
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 03:36:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Craig Kelley 2001-03-08 23:03:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.1-0.1.9 i686; en-US; 0.9)
Gecko/20010305

I have a Logitech Wheel Mouse PS/2, but both anaconda and mouseconfig say
it must be USB.  :)  I tried the USB option on installation and it freaked
out the first time X11 started up.  I re-ran mouseconfig and lied by saying
it was a generic 3-button mouse and then manually edited
/etc/X11/XF86Config to uncommont the ZAxisMapping there (it worked fine
after that).

Kudos on the new installer.  It autodetected *everything* in my system
(Radeon 32DDR, 3Com NIC, even my 21" monitor!).  I like it.

Comment 1 Matt Wilson 2001-03-08 23:05:56 UTC
which selection did you choose in mouseconfig that made a non-working X
configuration?



Comment 2 Craig Kelley 2001-03-09 03:10:17 UTC
I chose Logitech Wheel Mouse (USB), which caused X11 to not start.  It *is* a Logitech Wheel Mouse, but it is PS/2 and not USB.

Comment 3 Bill Nottingham 2001-03-09 03:23:06 UTC
Do you have a USB keyboard?

Comment 4 Craig Kelley 2001-03-09 03:35:17 UTC
No.  There were plenty of PS/2 options in the anaconda/mouseconfig window, but the Logitech Wheel Mouse wasn't one of them.  You just need to add a 
new entry that is just like the Logitech Wheel Mouse (USB), but make /dev/mouse a soft link to /dev/psaux instead of USB.

Comment 5 Craig Kelley 2001-03-09 03:36:02 UTC
(And call it Logitech Wheel Mouse (PS/2) instead)

Comment 6 Matt Wilson 2001-03-09 03:48:41 UTC
don't select the "USB" option if you don't have a USB mouse.
I'll see about adding an entry.


Comment 7 Josh Cogliati 2003-07-02 14:13:24 UTC
On the other hand, if you have a USB mouse, and set the protocol to USB, X11
will not start.  Also the mouse wheel will not work.


Note You need to log in before you can comment on or make changes to this bug.