Bug 311181 - smolt is gathering SELinux data incorrectly
Summary: smolt is gathering SELinux data incorrectly
Status: CLOSED DUPLICATE of bug 255101
Alias: None
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Mike McGrath
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-28 15:32 UTC by Daniel Walsh
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 15:36:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Walsh 2007-09-28 15:32:36 UTC
Description of problem:

Looks like smolt is trying to collect SELinux info, but doing so
incorrectly.  Looking at the code, it is
running /usr/sbin/selinuxenabled and collecting the return code and
running getenforce - You can also use the python bindings to libselinux.

import selinux
print selinux.is_selinux_enabled()
print selinux.get_enforcemode()

Comment 1 Mike McGrath 2007-09-28 15:34:30 UTC
This is mostly because I don't know what the heck I'm doing :)  I'll get that 
bit of logic put in today.

Comment 2 Daniel Walsh 2007-09-28 15:36:18 UTC

*** This bug has been marked as a duplicate of 255101 ***


Note You need to log in before you can comment on or make changes to this bug.