Bug 31132 - Gnome up2date agent windows expand beyond 800x600 resolution
Gnome up2date agent windows expand beyond 800x600 resolution
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-08 20:43 EST by David Lamm
Modified: 2015-01-07 18:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 00:22:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Lamm 2001-03-08 20:43:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)


When using the Gnome up2date agent on an 800x600 screen the window size 
can increase beyond the 600 pixel height.
Example:  After a fresh install of Wolverine, use the Gnome up2date 
agent.  Choose to update the optional Xfree86 rpm package.  When the 
download begins, the screen expands to show the entire description of the 
Xfree86 package.  This is greater than the 600 pixel height of the screen 
so the top and bottom of the window become hidden.  The buttons on the 
bottom of the screen also become hidden, and there seems to be no way to 
make the window any smaller.   Fortunately, hitting the enter key seems to 
continue the install process.

This only seems to happen if the package description is greater than a 
certain size.

A good solution would be to have the package description displayed in a 
scrollable window.

Reproducible: Always
Steps to Reproduce:
1.Run the Gnome up2date agent in an 800x600 screen
2.Choose a package that has a very large description
3.
	

Actual Results:  Window grew beyond the 600 pixel height of the screen

Expected Results:  The up2date window should never expand beyond the 
resolution of the screen
Comment 1 Preston Brown 2001-03-09 00:22:07 EST
fixed in CVS.
Comment 2 Preston Brown 2001-03-22 12:27:12 EST
now fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.