Bug 31143 - Some keys can't be input by USB 106 keyboard
Summary: Some keys can't be input by USB 106 keyboard
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-09 06:11 UTC by Bill Huang
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-11 05:56:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
keybdev patch (1.04 KB, text/plain)
2001-03-09 06:12 UTC, Bill Huang
no flags Details
XF86Config (16.14 KB, text/plain)
2001-03-09 09:57 UTC, Bill Huang
no flags Details
lspci (743 bytes, text/plain)
2001-03-09 09:59 UTC, Bill Huang
no flags Details

Description Bill Huang 2001-03-09 06:11:13 UTC
(Originalle reported by Hitachi tester)

Some keys can't be input by USB 106 keyboard
on Console: can't input "|","\"and "_"
on X window: can't input "_" and "\"

Test machine: Hitachi FLORA 310LV LA1
Chiptset: i810E
USB keyboard

Here is the spec of the machince
http://www.hitachi.co.jp/Prod/comp/OSD/pc/flora300/spec/310_la1.htm

Now this bug has been fixed on  Laser5 Linux 6.4.
Since there is no ps2 port on this serial machine,only usb ports are used.
The bug was occured in Fisher and Wolverine.

There are some discussion on the url below.(Sorry,in Japanese)
http://his.luky.org/ML/linux-users.7/msg04489.html

Here are some possible reasons:
1)It is not enough to use scancode of ps/2 keyboard for usb keyboard,AT set
2 and AT set3 shall also be defined for USB keyboard.

2)The patch may fix the bug.the file is attached.

Comment 1 Bill Huang 2001-03-09 06:12:51 UTC
Created attachment 12165 [details]
keybdev patch

Comment 2 Bill Huang 2001-03-09 09:57:58 UTC
Created attachment 12170 [details]
XF86Config

Comment 3 Bill Huang 2001-03-09 09:59:04 UTC
Created attachment 12171 [details]
lspci

Comment 4 Pete Zaitcev 2001-04-06 06:47:07 UTC
I do not understand if the Laser5 patch is safe.
Davem says it may impair keyboards with additional
keypad characters KeyPAD-comma or KeyPAD-RightPAREN.
I sent a question to Vojtech, so far no reply.


Comment 5 Pete Zaitcev 2001-08-02 21:14:46 UTC
Opening the bug to the public -
if Lazer5 ships the fix, should be no problem.
The 7.1 release passed too.

Still talking to Vojtech about the fix, believe it or not :)



Comment 6 Pete Zaitcev 2001-08-11 05:56:33 UTC
The plot thickens. Somebody filed a Bug 51142.
However, they refer to TurboWS, which has a
different change (not even overlappting with Lazer5).

Lazer5 changes USB offsets 0x7c (backslash, underscore),
0xb4 (Yen, pipe). Turbo changes 5 symbols, at offsets
from 0xb5 to 0xb9, with resulting codes for 5 additional
keys. See http://euc.jp/i18n/jpkbd.en.html.

Can anyone with access to the hardware define DEBUG in
drivers/usb/hid.c and send me output for each particular key?
(Do not define DEBUG_DATA).



Comment 7 Pete Zaitcev 2001-08-19 16:36:56 UTC
I think Lazer5 is full of it - scancodes are not where they
have to be. Look at #51142 for the reference and contact
Nakai-san for userland questions.



Note You need to log in before you can comment on or make changes to this bug.