Bug 31156 - sort coredumps
Summary: sort coredumps
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: textutils (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-09 13:27 UTC by martin.macok
Modified: 2017-11-14 20:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 13:27:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description martin.macok 2001-03-09 13:27:12 UTC
$ sort tags >/dev/null
zsh: segmentation fault (core dumped)  sort tags > /dev/null
$ df /tmp          
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/hda6                48770     31678     14574  69% /tmp


The file 'tags' is 30MB big. When I sort it with -S 60M it work good.

And it lookes like 'sort' ignores '-T /var/tmp' or TMP=/var/tmp or TMPDIR=/var/tmp ...

Comment 1 Bernhard Rosenkraenzer 2001-03-12 09:44:09 UTC
Can't reproduce this in the current version (2.0.11-6)



Comment 2 martin.macok 2001-03-12 10:14:07 UTC
I can confirm that RESOLVED. I upgraded to current rawhide (textutils-2.0.11-6)
and sort doesn't coredump. It also honoures TMP/TMPDIR settings and -T switch.


Note You need to log in before you can comment on or make changes to this bug.