Bug 31195 - rpm should inform user that /etc/rpmrc and ~/.rpmrc is obsolete
rpm should inform user that /etc/rpmrc and ~/.rpmrc is obsolete
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-09 13:05 EST by Vidar Langseid
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 13:10:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidar Langseid 2001-03-09 13:05:51 EST
Hi

I tried to owerride topdir using /etc/rpmrc and ~/.rpmrc:
topdir: /mytopdir

I did also try do use tags like vendor and packager
This resulted in error messages like:
  bad option 'topdir' at /etc/rpmrc:1
  bad option 'vendor' at /etc/rpmrc:2
  bad option 'packager' at /etc/rpmrc:3

Then I instead tried to create ~/.rpmmacros :
%_topdir    /mytopdir
%vendor    foo
%packager  bar

This worked !!!!!

I think that rpm should have given me a better errormessage when I tried to
use a rpmrc file, especially when resouces like MaximumRPM states :"The
vendor entry is a great example of a good candidate for inclusion in
/etc/rpmrc"
Comment 1 Vidar Langseid 2001-03-09 13:10:32 EST
This bug also applies to RedHat 7.0
Comment 2 Jeff Johnson 2001-03-09 22:16:55 EST
Yes "Maximum RPM" is out of date, not much can be done.

There's an error message already with legacy syntax, what needs doing more is to
remove rpmrc configuration entirely, that will happen eventually.

Note You need to log in before you can comment on or make changes to this bug.