Bug 312 - PHP3 does not recognize commands to connect to PostgreSQL
PHP3 does not recognize commands to connect to PostgreSQL
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mod_php3 (Show other bugs)
5.2
i386 Linux
high Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-12-05 11:45 EST by beholder
Modified: 2007-06-08 13:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-12-05 12:46:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description beholder 1998-12-05 11:45:14 EST
When using PHP3 to connect a web page to a PostgreSQL
database, even the most basic PHP commands fail.

Here is an example:

This is the line in my HTML code that according to PHP's
documentation, should have no problems:

<?
$conn = pg_connect("","","","","icwf");
?>

However, when I try to load the page with this code in it,
I get this error message:

Fatal error: Call to unsupported or undefined function
pg_connect() in /home/httpd/html/icwf/roster.php3 on line 10

pg_connect is a BASIC PHP command!  I should not have to
define it, because PHP should already parse and handle it.
If the mod_php3 was not compiled to enable access to
PostgreSQL from a web page, then it should be as quickly as
possible.  This eliminates the ability to do online
shopping, or any other application for which web pages and
databases must connect.
Comment 1 Cristian Gafton 1998-12-05 12:46:59 EST
php3 does not have postgresql support compiled in.
Comment 2 paolo.saggese 1999-02-03 07:43:59 EST
> If the mod_php3 was not compiled to enable access to
> PostgreSQL from a web page, then it should be as quickly as

I agree 110%.

This may not be really a bug of the package, but, IMHO, may very well
be seen as a bug of the distro... that is, since you package Apache
and mod_php3 as well as PostgreSQL as standard components of the
distro, anyone (at least, I) would expect to be able to use php3 to
access local PostgreSQL databases from the WWW.

I was just wondering about this problem, when I read this entry in
bugzilla!  Hope you'll consider to change this for the next release.

Tnx & Regards,
				  Paolo.

Note You need to log in before you can comment on or make changes to this bug.