Bug 3120 - linuxconf doesn't generate dip for slip
linuxconf doesn't generate dip for slip
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 3371 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-28 10:16 EDT by rri0189
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 10:36:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rri0189 1999-05-28 10:16:40 EDT
linuxconf claims to set up ppp/slip sessions (and is
recommended for doing so in the install manual), but the
slip feature doesn't work, because the rest of the system
(e.g., usernet) wants a dip script for slip, and linuxconf
only creates a chat script.

netcfg does the same, but attempts (with rather poor
success, but that's another problem) to translate the chat
script that it creates into a dip script.
Comment 1 Jay Turner 1999-06-28 12:14:59 EDT
This issue has been forwarded to a developer for further action.
Comment 2 Michael K. Johnson 1999-07-13 11:54:59 EDT
Component changed to initscripts because I think that ifup-slip
should create the dip script on the fly if the chat script exists
and the dip script does not.
Comment 3 Bill Nottingham 1999-08-24 12:04:59 EDT
I disagree - doing on the fly conversion in the initscripts is
silly; linunconf should integrate with the rest of the system.
Comment 4 Michael K. Johnson 1999-10-04 16:08:59 EDT
*** Bug 3371 has been marked as a duplicate of this bug. ***

When setting up a slip interface with linuxconf under RH6.0,
linuxconf creates
/etc/sysconfig/network-scripts/chat-$DEVICE.  Unfortunately,
RedHat's network scripts (ifup-sl) expect to find a dip
script (/etc/sysconfig/network-scripts/dip-$DEVICE).

Workaround: use control-panel (netcfg) to set up network
interfaces.
Comment 5 Trond Eivind Glomsrxd 2000-09-13 19:10:18 EDT
Currently, rp3 (and rp3-config) is the recommended and working way of doing
this  (added in Red Hat Linux 6.1)

Note You need to log in before you can comment on or make changes to this bug.