Bug 312131 - Pidgin should not be built against Avahi's HOWL compatibility layer
Pidgin should not be built against Avahi's HOWL compatibility layer
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-29 00:55 EDT by Michel Alexandre Salim
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-18 18:36:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff for pidgin.spec (1.15 KB, patch)
2007-09-29 00:55 EDT, Michel Alexandre Salim
no flags Details | Diff

  None (edit)
Description Michel Alexandre Salim 2007-09-29 00:55:01 EDT
Description of problem:
Since 2.1.1 pidgin has supported the native Avahi API for building the Bonjour
plugin. Fedora currently still builds Pidgin against the old HOWL compatibility
layer.

Version-Release number of selected component (if applicable):
pidgin-2.2.0-2.fc8

How reproducible:
Always

Steps to Reproduce:
1. Run pidgin from the command line
2. Turn on Bonjour plugin
  
Actual results:
Warning in stderr that the HOWL compatibility layer should not be used

Additional info:
As an aside, the BuildReq on mozilla-nss-devel should now be nss-devel (which
provides the former). Unless pidgin is available on platforms without nss-devel?
Comment 1 Michel Alexandre Salim 2007-09-29 00:55:01 EDT
Created attachment 211241 [details]
Diff for pidgin.spec
Comment 2 Warren Togami 2007-09-29 03:49:04 EDT
The spec still supports distros going all the way back to RHEL3. 
mozilla-nss-devel works from RHEL3 through F8, so we'll keep it this way for now.

Good catch about the avahi thing.  Adding.
Comment 3 Warren Togami 2007-09-29 03:52:38 EDT
Keeping open until this hits rawhide and someone has confirmed that it works.
Comment 4 Michel Alexandre Salim 2007-09-29 15:26:44 EDT
Just tested the build from Koji and it works (against Pidgin on Windows with
Apple Bonjour)
Comment 5 Michel Alexandre Salim 2007-09-29 15:34:32 EDT
Forgot to mention -- I've tried rebuilding Pidgin against avahi-0.6.14 (on
openSUSE 10.2) and it did not work (building against 0.6.14's howl layer works),
so on older releases we might still need to build against compat-howl
Comment 6 Warren Togami 2007-09-30 22:29:38 EDT
RHEL5       has avahi-0.6.16
FC6 updates has avahi-0.6.16
F7  updates has avahi-0.6.17
F8          has avahi-0.6.21

Could you please figure out where it began working?
Comment 7 Michel Alexandre Salim 2007-10-03 20:09:22 EDT
Pidgin 2.2.1 is out.

Seems like I remembered wrongly, looks like it builds just fine with older avahi
as well. In any case, it's a build-time failure, so it should be easy to notice
any failure.

I think the SUSE problem is that they don't have avahi-glib-devel -- the .pc was
included in avahi-devel but does not pull in avahi-glib itself.

(I would do a scratch build, but for FC6 meanwhile is part of -extras, and for
RHEL one has to exclusively use Plague; as far as I can see it does not allow
for scratch builds?)

Note You need to log in before you can comment on or make changes to this bug.