Bug 312201 - kernel hangs at boot while running udev
kernel hangs at boot while running udev
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-29 04:34 EDT by Dino Sangoi
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 05:42:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot log from kernel 211 until hang. (183.57 KB, text/plain)
2007-09-29 04:34 EDT, Dino Sangoi
no flags Details
Boot log from kernel 211, lots of sysrq-P pressed after hang (301.71 KB, text/plain)
2007-10-01 16:50 EDT, Dino Sangoi
no flags Details

  None (edit)
Description Dino Sangoi 2007-09-29 04:34:25 EDT
Description of problem:

Kernels starting at 2.6.23-0.202.rc8.fc8 (tried 2.6.23-0.202.rc8.fc8,
2.6.23-0.204.rc8.fc8 and 2.6.23-0.211.rc8.git2.fc8) hangs while running udev.
Kernels before and up to 2.6.23-0.195.rc7.git3.fc8 works fine.

Version-Release number of selected component (if applicable):
2.6.23-0.202.rc8.fc8 and newer.

How reproducible:
Always

Steps to Reproduce:
1. boot kernel 202 or greater
  
Actual results:
Hangs after 'Starting udevd...'

Expected results:
Booting machine.

Additional info:
hardware:
http://smolt.fedoraproject.org/show?UUID=d6158ae5-29cf-4280-9e3d-6256b4ae9d64

lspci and other info found in bug #240343 (if more info is needed just ask).

I have loaded netconsole from initrd (patching it), and I have attached the full
boot until the hang, and the output got pressing SysRQ-<almost-everything>
Comment 1 Dino Sangoi 2007-09-29 04:34:25 EDT
Created attachment 211271 [details]
Boot log from kernel 211 until hang.
Comment 2 Dino Sangoi 2007-09-29 11:12:39 EDT
Vanilla kernel from git works, I tried:

$  git-clone
git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux-2.6.git linux-2.6
$ cd linux-2.6
$ git log | head -1
commit 1bef7dc00caa7bcbff4fdb55e599e2591461fafa
$ cp /boot/config-2.6.23-0.211.rc8.git2.fc8 .config
$ make oldconfig
$ make
$ su
Password:
# make modules_install install
# reboot

And this kernel starts udev just fine and works. 
Comment 3 Dino Sangoi 2007-09-29 12:27:06 EDT
kernel 2.6.23-0.214.rc8.git2.fc8 still broken.
Comment 4 Chuck Ebbert 2007-10-01 14:37:45 EDT
Process events/0 is spinning. Can you do sysrq-P multiple times to see where it
is stuck?
Comment 5 Dino Sangoi 2007-10-01 16:50:13 EDT
Created attachment 212871 [details]
Boot log from kernel 211, lots of sysrq-P pressed after hang

There is the boot log after pressing lots of sysrq-P. Kernel is always 211.
There is also a sysrq-T just in case the processes are different.

overall it looks very boring to my kernel-illiterate eyes: only ESI, EDI, EBX
and ECX seems to change. ESI and EDI seems to grow together, so I waited for
them to warp around, but nothing happened :-/

Tell me if I can try something else.
Comment 6 Dino Sangoi 2007-10-18 09:03:21 EDT
kernel 2.6.23-6.fc8.i686 is still broken, but I did a "bisection" downloading
from koji all the kernels between kernel-2.6.23-0.195.rc7.git3.fc8.i686 (the
last good) and kernel-2.6.23-0.202.rc8.fc8.i686 (the first bad), and I found
that kernel-2.6.23-0.197.rc7.git5.fc8.i686 works, while
kernel-2.6.23-0.198.rc7.git5.fc8.i686 is broken. The only difference between
those kernels is the updated linux-2.6-highres-timers.patch. Sadly the changes
between the old version (in 197) and new version (in 198) are big.

I will try compiling 198 with the old patch, or without if it doesn't apply.
Comment 7 Dino Sangoi 2007-11-05 06:17:08 EST
kernel-2.6.23.1-42.fc8 still hangs, But I have some more info:
- vanilla 2.6.24-rc1 hangs, while vanilla 2.6.23 works.
- a git bisect on vanilla kernel points to commit
4f86d3a8e297205780cca027e974fd5f81064780 as the first bad commit. This is the
first commit after v2.6.23!
- passing the 'nolapic' parameter fixes the problem for all the hanging kernels.

I will try reporting the regression to LKML.
Comment 8 Chuck Ebbert 2007-11-05 15:22:14 EST
That commit is the cpuidle code; Fedora 8 had that before it went into 2.6.24-rc
so it makes sense that it is the cause of this problem.
Comment 9 Dino Sangoi 2007-11-12 05:42:45 EST
I moved this bug to uptream bugzilla:
http://bugzilla.kernel.org/show_bug.cgi?id=9355

Note You need to log in before you can comment on or make changes to this bug.