Bug 31232 - Radeon is not 3D accelerated nor DGA compiled
Radeon is not 3D accelerated nor DGA compiled
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-09 16:34 EST by Craig Kelley
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 12:35:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My XF86Config file (16.01 KB, text/plain)
2001-03-12 16:20 EST, Craig Kelley
no flags Details
My XF86Config-4 file (3.68 KB, text/plain)
2001-03-12 16:21 EST, Craig Kelley
no flags Details
My XFree86 log (89.56 KB, text/plain)
2001-03-12 16:25 EST, Craig Kelley
no flags Details

  None (edit)
Description Craig Kelley 2001-03-09 16:34:56 EST
Radeon driver, contrary to the release notes for Wolverine, is *not* 3D
accelerated (and I'd be surprised since CVS DRI doesn't even work right now
either -- at least not on my 32DDR).  It also does not have DGA enabled,
which considerably slows down VMWare.  The default XFree86-4.0.2 works
better in this regard than the RPM shipped with Wolverine because it
enables DGA by default for normal user access.

Here's the output on my system of glxinfo:


[ink@desconocido ink]$ glxinfo
display: :0.0  screen:0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context, 
    GLX_ARB_get_proc_address
GLX extensions:
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
OpenGL vendor string: VA Linux Systems, Inc.
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 Mesa 3.4
OpenGL extensions:
    GL_ARB_multitexture, GL_ARB_texture_cube_map, GL_ARB_tranpose_matrix, 
    GL_EXT_abgr, GL_EXT_blend_color, GL_EXT_blend_func_separate, 
    GL_EXT_blend_logic_op, GL_EXT_blend_minmax, GL_EXT_blend_subtract, 
    GL_EXT_clip_volume_hint, GL_EXT_compiled_vertex_array,
GL_EXT_histogram, 
    GL_EXT_packed_pixels, GL_EXT_paletted_texture, GL_EXT_point_parameters, 
    GL_EXT_polygon_offset, GL_EXT_rescale_normal, 
    GL_EXT_shared_texture_palette, GL_EXT_stencil_wrap, GL_EXT_texture3D, 
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_object, 
    GL_EXT_texture_lod_bias, GL_EXT_vertex_array, GL_HP_occlusion_test, 
    GL_INGR_blend_func_separate, GL_MESA_window_pos,
GL_MESA_resize_buffers, 
    GL_NV_texgen_reflection, GL_PGI_misc_hints, GL_SGI_color_matrix, 
    GL_SGI_color_table, GL_SGIS_pixel_texture, GL_SGIS_texture_edge_clamp, 
    GL_SGIX_pixel_texture

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x25 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x26 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
Comment 1 Mike A. Harris 2001-03-09 19:16:23 EST
The release notes for Wolverine are wrong.  Unfortunately, someone
mistakenly put that Radeon 3D was supported in Wolverine in one spot,
and then in another spot that it wasn't.  Radeon accelerated 3D is not
and will not be supported in XFree86 4.0.2, nor in 4.0.3.  For the
brave, Radeon 3D is supported in the XFree86 CVS trunk code which is
available on the http://www.xfree86.org website.

Any problems with VMware should be taken up with VMware technical support.
There are known issues with VMware running under a 2.4.x kernel and the
Vmware people are working to fix this AFAIK.  I'm not aware of any problems
with DGA in our release.
Comment 2 Craig Kelley 2001-03-09 19:31:41 EST
VMWare works just fine under XFree86 4.0.2/Debian on this same box (kernel 2.4.1) -- When I attempt to run it under Wolverine (which is also using 
XFree86 4.0.2 with kernel 2.4.1) it says that my X11 server doesn't support DGA.  The VMWare installation in question resides on a separate partition 
and is exactly the same for both distributions.  I don't think this is a VMWare problem, but I don't have a RedHat 7.0 box handy to test on either.
Comment 3 Craig Kelley 2001-03-09 19:32:43 EST
(and, if anyone really is interested in 3D support for the radeon, you must get the DRI CVS tree from dri.sourceforge.net and not from xfree86.org)
Comment 4 Mike A. Harris 2001-03-09 21:20:51 EST
If you're using VMware with a 2.4.x kernel and not having problems, then
either:  A) You're not using functionality in VMware that triggers the
problems, or B) VMware has solved the problems that there were and released
an update.  I was under the assumption that such problems still existed due
to discussions taking place on linux-kernel@vger.kernel.org

For the Radeon thing.. You can try either the XFree86 trunk, or you can try
the stuff at sourceforge.  From what I understand, both work well, depending
on what snapshot you get.

I will look into the DGA thing again, however I will need a complete
attachment of your X server log, and configuration file.
Comment 5 Craig Kelley 2001-03-12 12:17:32 EST
Your Bugzilla doesn't allow attachments...  You can get the files here:

http://inconnu.isu.edu/~ink/wolverine/

You'll notice that the X11 log says:

 (II) Loading extension XFree86-DGA

But it doesn't work.  I tried UAE (another application which uses DGA), and it
also said that DGA dosn't work:

 "Your X server does not support XFree86 DGA accelerated graphics on your
  display hardware."

Comment 6 Mike A. Harris 2001-03-12 16:18:04 EST
Yes, bugzilla does allow file attachments.  If you look directly above the
box that you are typing your comment in you will see:

Attachments:  Create a new attachment (proposed patch, testcase, etc.)

Please attach your files using this feature.
Comment 7 Craig Kelley 2001-03-12 16:20:44 EST
Created attachment 12463 [details]
My XF86Config file
Comment 8 Craig Kelley 2001-03-12 16:21:27 EST
Created attachment 12464 [details]
My XF86Config-4 file
Comment 9 Craig Kelley 2001-03-12 16:25:08 EST
Created attachment 12465 [details]
My XFree86 log
Comment 10 Mike A. Harris 2001-03-30 05:56:48 EST
I believe that this DGA problem you and some others have been having is
because our XFree86 does not have the shared library libXxf86dga.so

I have just added it to the XFree86-4.0.3-5 build.  If it works ok, I will
leave it in.  I think this will fix this problem.  Can you run the following
command and report back to me here what it says:

ldd $(which vmware)
Comment 11 Craig Kelley 2001-03-30 12:35:48 EST
$ ldd `which vmware`
	/lib/libNoVersion.so.1 => /lib/libNoVersion.so.1 (0x40017000)
	libm.so.6 => /lib/libm.so.6 (0x40023000)
	libdl.so.2 => /lib/libdl.so.2 (0x40044000)
	libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40049000)
	libXtst.so.6 => /usr/X11R6/lib/libXtst.so.6 (0x40128000)
	libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x4012e000)
	libXi.so.6 => /usr/X11R6/lib/libXi.so.6 (0x4013c000)
	libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x40144000)
	libXp.so.6 => /usr/X11R6/lib/libXp.so.6 (0x40191000)
	libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4 (0x40199000)
	libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x401a8000)
	libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x401bf000)
	libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x401d6000)
	libc.so.6 => /lib/libc.so.6 (0x401df000)
	/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

Comment 12 Mike A. Harris 2001-05-04 06:00:21 EDT
DGA works fine for me on all 3 of my Radeons.  If you are still having problems,
update to our current release as that is what I'm using and not having any
trouble.

Note You need to log in before you can comment on or make changes to this bug.