Bug 31257 - STARTER_SIZE should be larger
Summary: STARTER_SIZE should be larger
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: memprof   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-10 01:15 UTC by Christian Bauer
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-13 09:53:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christian Bauer 2001-03-10 01:15:38 UTC
While trying to profile a C++ program that uses the CLN library with
memprof I kept getting the message "MemProf: Starter malloc exceeded
available space". I fixed this by increasing STARTER_SIZE in memintercept.c
(line 68) from 1k to 32k (to be on the safe side). I'm not exactly sure
what the STARTER_SIZE is for and why a C++ program would require a larger
value (static objects), but the default seems be too low.

Comment 1 Toralf 2001-06-11 12:25:18 UTC
We have the same problem. In it's current state, memprof is really quite
useless. Why is no updated version available???

Comment 2 Toralf 2001-06-11 16:20:59 UTC
I've now updated and built the utilitly via sources checked out from the GNOME
CVS. Note that STARTER_SIZE of 32k wasn't even enough for me, I'm now using

#define STARTER_SIZE 128*1024


Comment 3 Toralf 2002-03-13 09:53:50 UTC
It disappoints me that nobody has tried to address this issue. We are now
getting the problem once again because we have upgraded to Red Hat 7.2,
overwriting the patched version...

Comment 4 Owen Taylor 2002-08-21 18:44:34 UTC
memprof-0.5.0-2 in Rawhide fixes this by changing the way memprof
handles intialization. I haven't seen problesm with any of the 
C++ programs I've tried.


Note You need to log in before you can comment on or make changes to this bug.