Bug 3126 - rpc.yppasswdd dies after you run yppassd "username"
rpc.yppasswdd dies after you run yppassd "username"
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
6.0
All Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
http://192.233.54.81
:
: 3478 3826 4724 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-28 12:25 EDT by michael.waite
Modified: 2015-01-07 18:37 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-29 13:35:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michael.waite 1999-05-28 12:25:31 EDT
When you run yppasswd "username" the password gets changed
and then the deamon dies. ie rpc.yppasswdd.  A core gets
generated. If you restart the deamon you can then change
another password before it then dies. We are running this on
a Compaq Proliant 5500 dual 400 zeons. I sent mail to
Thursten and he says that he can't duplicate it and is not
going to do anything to fix it because he needs to see more
bug reports.
Comment 1 Jeff Johnson 1999-05-29 13:35:59 EDT
Fixed in ypserv-1.3.6.92-2.
Comment 2 Jeff Johnson 1999-06-15 10:43:59 EDT
*** Bug 3478 has been marked as a duplicate of this bug. ***

I have found that rpc.yppasswdd dies every time you run
"yppasswd username".
I have confirmed this with several other members of
hedwig-list@redhat.com.
Thorsten Kukuk had no answer as he can not replicate the
problem on their
os. I have updated the yp tools to the latest
ypserv-1.3.6.92 vintage and
the problem remains.
The mail list members that are experiencing the same problem
that I am, all
agree that it has nothing to do with pilot error on yp
client installations
as we get the same errors on hpux, Tru64UNIX, Redhat Linux,
etc etc etc.
Comment 3 Jeff Johnson 1999-06-30 18:47:59 EDT
*** Bug 3826 has been marked as a duplicate of this bug. ***

I'm running an NIS master with the rpc.yppasswdd deamon
running (started from /etc/rc/init.d/yppasswdd).  Every
time a user uses yppasswd to change his/her password, the
rpc.yppasswdd correctly makes the change and then dies.
Happens every time.  I then have to manually restart
rpc.yppasswdd, but then after the next user uses yppasswd,
rpc.yppasswdd is dead again.

Surely there is a reason for this?  Any ideas?

System: RedHat 6.0 in Intel PII machines.
Comment 4 Jeff Johnson 1999-08-26 14:31:59 EDT
*** Bug 4724 has been marked as a duplicate of this bug. ***

When I try to change a NIS password, the first time all goes
right. Before the password change, the YPPASSWD service
stops, resulting in an RPC's Unable to receive error.

I've managed to partially solution this problem editing
the /etc/rc.d/init.d/yppasswd script and creating another
script that calls the previous script after the yppasswd
command.

Note You need to log in before you can comment on or make changes to this bug.