Bug 312831 - Kmail does not recognise X509 signatures
Summary: Kmail does not recognise X509 signatures
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdepim (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-30 03:10 UTC by Graeme Nichols
Modified: 2017-05-19 15:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-03 16:13:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Graeme Nichols 2007-09-30 03:10:40 UTC
Description of problem:
Kmail fails to recognise an email signed by an X509 certificate resulting in the
failure to import the cert/key to enable encryption of an email to the sender of
the signed email. This works just fine in Thunderbird.

Version-Release number of selected component (if applicable):
KSEPIM-3.5.7-3.fc7; gnupg2-2.0.6-2.fc7; gpgme-1.1.4-1.fc7

How reproducible:
Simply receive an email signed by the sender's X509 certificate. Kmail will
respond with the error "Not enough information to check Signature" and "Status:
No status information available." Clicking on the "Details' link will show the
correct details for the sender's signature.


Steps to Reproduce:
1. Receive an email signed with the sender's X509 certificate
2. See above
3.
  
Actual results:
Signature not recognised


Expected results:
Signature recognised and the cert/key automatically imported into
keyring/certificate cache. Thunderbird behaves as expected.

Additional info:

Comment 1 Rex Dieter 2007-10-03 16:13:11 UTC
From following upstream ml, looks like for this functionality to work properly,
on e needs to have 'dirmngr' pkg installed.

It would seem gnupg2 would be the right place to add a dependency, as it is
gpgsm that does the interaction with dirmngr.

gnupg2 rawhide changelog:
* Wed Oct 03 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 2.0.7-2
- Requires: dirmngr (#312831)

This will seep back as an F-7 update soon.


Note You need to log in before you can comment on or make changes to this bug.