Bug 312901 - Black screen when returning from suspend
Black screen when returning from suspend
Status: CLOSED DUPLICATE of bug 358671
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 06:11 EDT by Kyrre Ness Sjøbæk
Modified: 2007-12-11 05:17 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 05:05:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My xorg.conf (1.17 KB, text/plain)
2007-10-04 02:53 EDT, Kyrre Ness Sjøbæk
no flags Details
Xorg log (67.41 KB, text/plain)
2007-10-04 02:59 EDT, Kyrre Ness Sjøbæk
no flags Details
Xorg.log with autoconfigured X11 (131.26 KB, text/plain)
2007-10-04 03:56 EDT, Kyrre Ness Sjøbæk
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2007-09-30 06:11:06 EDT
Description of problem:
When the laptop is comming out of suspend, the screen is black (backlight is
on). The only way to get it back on line is to switch to a VT (which also is
black), and then back to X11.

Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.0.0-4.fc7

How reproducible:
Every time

Steps to Reproduce:
1. Put machine in suspend (hit "suspend" in gnome)
2. Wake machine up
3. LCD is black
  
Actual results:
LCD is off after suspend, VT doesnt work. Backlight on.

Expected results:
LCD on after suspend, VT's work

Additional info:

This is a Dell Latitude D520 laptop.

The LCD actually flickers on for a short moment when the laptop is coming up.

Relevant lspci:
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
        Subsystem: Dell Unknown device 01d4
        Flags: bus master, fast devsel, latency 0
        Capabilities: [e0] Vendor Specific Information

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03) (prog-if 00 [VGA])
        Subsystem: Dell Unknown device 01d4
        Flags: bus master, fast devsel, latency 0, IRQ 16
        Memory at eff00000 (32-bit, non-prefetchable) [size=512K]
        I/O ports at eff8 [size=8]
        Memory at d0000000 (32-bit, prefetchable) [size=256M]
        Memory at efec0000 (32-bit, non-prefetchable) [size=256K]
        Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0
Enable-
        Capabilities: [d0] Power Management version 2

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML
Express Integrated Graphics Controller (rev 03)
        Subsystem: Dell Unknown device 01d4
        Flags: bus master, fast devsel, latency 0
        Memory at eff80000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [d0] Power Management version 2

I am not completely shure about choice of component, please set correctly if
wrong component.
Comment 1 Matěj Cepl 2007-10-02 06:23:32 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Kyrre Ness Sjøbæk 2007-10-04 02:53:24 EDT
Created attachment 215481 [details]
My xorg.conf
Comment 3 Kyrre Ness Sjøbæk 2007-10-04 02:59:28 EDT
Created attachment 215491 [details]
Xorg log

Suspended and resumed the computer right before copying out this file. Also had
to do the VT-switch trick in order to get back to X11 to post this in firefox.
Comment 4 Kyrre Ness Sjøbæk 2007-10-04 03:56:24 EDT
Created attachment 215541 [details]
Xorg.log with autoconfigured X11

After rebooting the computer to single user mode - the VTs are gone after a
suspend... - and then init 3, fix the setup [remove xorg.conf, remove old log
file], and then init 5, login [wrong keyboard setup], i got this file.

Strangely, the screen seems unsharp...

Trying to suspend/resume next...
Comment 5 Kyrre Ness Sjøbæk 2007-10-04 04:05:10 EDT
Hmm... I can't resume when xorg.conf is gone. Tried two times, display was dead
on resume (however, network lights etc. started to blink "as usual", so i think
the laptop was working, just no LCD backlight... I have seen this happend with
the usual xorg.conf as well, but *very* seldom)

Also noted, when booting from "scratch", there where some colorful flicker when
starting rhgb at the bottom of the screen, not normally seen.
Comment 6 Brennan Ashton 2007-12-08 17:14:18 EST
I am wondering why this is marked as low, some people (like myself) are very
dependent on the Terminals, also when X messes up, it can be the only way to fix
it with out hard powering off the computer.
Comment 7 Kyrre Ness Sjøbæk 2007-12-08 18:07:30 EST
Well, while it (most commonly) messes up terminals, it is very possible to get
X11 back - hit control-alt-f1 to switch to a (dead) terminal, and then back
again to X11 with control-alt-f7.

You may need to wait a little before it comes back, but it does work.

Note that i have seen no crashes on suspend the last couple of months (but most
will *think* it has crashed, as the display doesn't come up unless you do this
trick)

One more thing: It seems to depress the "enter" key on the keyboard when waking
up from suspend (not literally - the keyboard is untouched, but the software
think it has been depressed for the 10-15 secounds the resume takes) - quite
annoying when you are editing a text document, or an icon to start a program was
highligthed when suspending...
Comment 8 Brennan Ashton 2007-12-08 18:18:41 EST
VTs can be made functional by executing  
insmod vga16fb 
You still have to do the terminal switching trick, but the terminals will be
functional.
Comment 9 Kyrre Ness Sjøbæk 2007-12-09 05:11:42 EST
Dupe?
https://bugzilla.redhat.com/show_bug.cgi?id=358671
Comment 10 Matěj Cepl 2007-12-10 09:04:35 EST
(In reply to comment #9)
> Dupe?
> https://bugzilla.redhat.com/show_bug.cgi?id=358671

Just to confirm this suspicion, reporter, could you reproduce this bug when
suspending your computer with?

pm-suspend --quirk-vbe-post

(or other quirks -- follow
http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-debug.html to find
out which quirks could be used for your computer).
Comment 11 Kyrre Ness Sjøbæk 2007-12-10 10:12:18 EST
Yes, that worked. When suspending using that command (instead of hitting
"suspend" in gnome), everything, including VT's, worked.

Note that the first time i tried to do this (after bringing it up from a suspend
initiated without this quirk), VT1 displayed gibberish, but the other VT's where
fine. Suspect reason is that i usually switch back and forth to VT1 in order to
get X11 back.

After a reboot, everything worked nicely, both X11 and all VTE's. Enter-bug is
still there, tough.

Will this quirk become default for my machine after an update? Is there any info
you need to know? It is a Dell latitude D520 with intel graphics as stated in
first comment.
Comment 12 Matěj Cepl 2007-12-11 05:05:37 EST
Two things:

a) so, this is really duplicate of bug 357661, so I am closing it as duplicate.
b) concerning the sending quirks upstream --
http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-report.html; it is
really the fastest way.

*** This bug has been marked as a duplicate of 357661 ***
Comment 13 Matěj Cepl 2007-12-11 05:17:06 EST
err, wrong duplicate number.

*** This bug has been marked as a duplicate of 358671 ***

Note You need to log in before you can comment on or make changes to this bug.