Bug 312981 - kernel 2.6.23-0.214.rc8.git2.fc8 b44 module suspend issues
kernel 2.6.23-0.214.rc8.git2.fc8 b44 module suspend issues
Status: CLOSED DUPLICATE of bug 240964
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2007-09-30 08:04 EDT by Luigi Tarenga
Modified: 2008-01-04 21:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-04 21:29:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luigi Tarenga 2007-09-30 08:04:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.6) Gecko/20070925 Fedora/2.0.0.6-10.fc8 Firefox/2.0.0.6

Description of problem:
i want to use the suspend mode on my Notebook: Dell Vostro 1700.
it works fine with fedora 7, it suspend and resume correclty.
i dosn't work on fedora test2 with kernel 2.6.23-0.214.rc8.git2.fc8
(it didn't worked even with the previous kernel, if i get it right there
is a regression bug with kernel 2.6.23)

Version-Release number of selected component (if applicable):
kernel-2.6.23-0.214.rc8.git2.fc8

How reproducible:
Always


Steps to Reproduce:
1. from Gnome put the Notebook in suspend mode
2. try to wake up it (i just press the power or the "home" key)
3.

Actual Results:
linux seems to read from hard disk but black screen left even after 
several minutes

Expected Results:
linux resume from suspended mode

Additional info:
Comment 1 Jon Stanley 2007-12-30 00:41:15 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 2 Luigi Tarenga 2008-01-02 19:35:45 EST
hi Jon,
now i'm using a fedora 8 installed from dvd and
i just updated the kernel to the version 2.6.23.9-85.fc8
i still have this issue. the system never wake up from a pm-suspend

what i can see once i try to wakeup the pc is the yellow word:
           Linux!

(same version of kernel on another laptop works fine, that one is
a packard bell with a ATI chipset i suppose)

i'm available for any kind of test!
Comment 3 Jon Stanley 2008-01-02 20:36:53 EST
Can you provide a link to a Smolt profile and please try any applicable quirks
listed at http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html
Comment 4 Luigi Tarenga 2008-01-04 15:20:28 EST
hi Jon,
here the smolt link:
http://www.smolts.org/show?UUID=cd3b2bd4-b912-4f4b-9805-c3de96497f88
unfortunally it doen't works for me, if you need i can attache a
smoltSendProfile output.

I discovered that pm-suspend works if i manually unload the b44 module.
I can suspend and resume the system if i do not have this module in memory.
It works from tty1 and from Xorg.
It works even if i create a file /etc/pm/config.d/unload_modules 
containing: SUSPEND_MODULES="b44"

now: should i close this bug?

many thanks for the suggestions.
Luigi

Comment 5 Jon Stanley 2008-01-04 21:10:09 EST
I don't think that closing it is appropriate, but changing the subject sure is.
 I'll do that.
Comment 6 Jon Stanley 2008-01-04 21:12:03 EST
I'll also reassign to network maintainer.
Comment 7 Jon Stanley 2008-01-04 21:29:03 EST
I'm thinking that this is actually a duplicate of bug 240964.  I will close this
one dup to that, and if we find later that it's different this bug can be re-opened.

*** This bug has been marked as a duplicate of 240964 ***

Note You need to log in before you can comment on or make changes to this bug.