Bug 313061 - evolution fails to represent URLs with ampersands correctly
evolution fails to represent URLs with ampersands correctly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtkhtml3 (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 09:38 EDT by Thomas J. Baker
Modified: 2007-12-11 16:03 EST (History)
1 user (show)

See Also:
Fixed In Version: gtkhtml3-3.16.2-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-11 16:03:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ebay email (7.35 KB, application/octet-stream)
2007-10-01 11:20 EDT, Thomas J. Baker
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 485700 None None None Never

  None (edit)
Description Thomas J. Baker 2007-09-30 09:38:26 EDT
An EBay email containing a link to an auction is misrepresented in evolution.
Mousing over the link displays the link in the status area with the ampersands
represented as "&". Clicking the link passes it to firefox with the same
error and copying the link also contains the error. 

I filed this against gtkhtml3 but it might be further up in evolution where the
error actually begins.

Here is an example mangled URL:

http://cgi.ebay.com/ws/eBayISAPI.dll?ViewItem&item=220155499798&ssPageName=ADME:B:SS:US:1
Comment 1 Matthew Barnes 2007-10-01 10:18:12 EDT
Evolution 2.12 / GtkHtml 3.16 seems to handle a random Amazon.com URL with
ampersands correctly for me.  I tried sending it to myself in both text/plain
and text/html, thinking the MIME type might be the key.  I couldn't reproduce
the problem in either case.

So that I can investigate further, can you please:

1) Indicate which version of Evolution and GtkHtml you were using.

2) Try to reproduce the problem after upgrading to the latest Evolution and
   GtkHtml packages in Rawhide.

3) If you still see the ampersand problem, export a sample mail exhibiting
   the problem as an mbox file and attach it to this bug.  Please remember
   to sanitize any sensitive data before posting.
Comment 2 Thomas J. Baker 2007-10-01 11:12:04 EDT
I'm already running rawhide:

evolution-2.12.0-3.fc8.x86_64
gtkhtml3-3.16.0-1.fc8.x86_64

I'll include an ebay search list email the next time I get one.
Comment 3 Thomas J. Baker 2007-10-01 11:20:30 EDT
Created attachment 212391 [details]
ebay email


Here is an ebay email that should show the problem. I don't think my sanitizing
messed anything up.
Comment 4 Milan Crha 2007-10-17 11:56:15 EDT
Hi Thomas, thanks for your data. It will be better to track this bug in upstream
bug http://bugzilla.gnome.org/show_bug.cgi?id=485700 , as you found it already,
so closing this one.
Comment 5 Thomas J. Baker 2007-10-23 13:20:39 EDT
Since you submitted a patch upstream, why couldn't it be applied to F8 gtkhtml?
This is quite an annoying bug for anyone who uses ebay.
Comment 6 Matthew Barnes 2007-10-23 13:39:39 EDT
The patch will be included in Fedora once upstream approves it.
Comment 7 Thomas J. Baker 2007-10-29 10:08:56 EDT
According to the referenced gnome bug report, the change has been committed
upstream by Milan. I'm willing to test private or koji builds.
Comment 8 Matthew Barnes 2007-10-29 23:06:26 EDT
Should be fixed in gtkhtml3-3.17.1-1.fc9.  Feel free to re-open if not.
Comment 9 Thomas J. Baker 2007-10-30 08:46:16 EDT
Yes it does. Is this going to make F8 release?
Comment 10 Matthew Barnes 2007-10-30 09:52:33 EDT
It won't make the initial release of Fedora 8 (that's frozen now) but it will be
included in the first stable update.
Comment 11 Thomas J. Baker 2007-11-28 21:50:09 EST
Just a ping to request this gets pushed to F8.
Comment 12 Matthew Barnes 2007-11-29 06:20:25 EST
This should be fixed in Evolution 2.12.2, which is available in Updates Testing.

http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/8/
Comment 13 Thomas J. Baker 2007-12-03 16:55:04 EST
The current release in updates testing seems to work fine.
Comment 14 Matthew Barnes 2007-12-11 16:03:25 EST
Thanks.  Closing this as CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.