Bug 313091 - [PATCH] Thinkpad ACPI not loaded on boot
[PATCH] Thinkpad ACPI not loaded on boot
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 10:29 EDT by Christopher Brown
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 08:07:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attachment to bring in acpi modules from drivers/misc (547 bytes, patch)
2007-09-30 10:29 EDT, Christopher Brown
no flags Details | Diff

  None (edit)
Description Christopher Brown 2007-09-30 10:29:41 EDT
Description of problem: Thinkpad ACPI component not loaded on boot.

Version-Release number of selected component (if applicable): Current (F7) and devel

How reproducible: Always


Steps to Reproduce:
1. Boot thinkpad
2. run lsmod
3. Note thinkpad_acpi not listed

Expected results: Thinkpad acpi module loaded on boot.

Additional info: This module move from drivers/acpi to drivers/misc in 2.6.22.
The reason for this being that the driver is not just ACPI stuff I believe. So
maybe there is a reason stuff in misc/ shouldn't be loaded. Anyway, I attach a
patch which really needs reviewing as I can't code my way out of a cardboard
box. Even though its a one-liner. Depressing huh?
Comment 1 Christopher Brown 2007-09-30 10:29:41 EDT
Created attachment 211771 [details]
Attachment to bring in acpi modules from drivers/misc
Comment 2 Bill Nottingham 2007-10-01 15:57:52 EDT
This is fixed in later kernels by adding dmi-based aliases to load the module
automatically.

Note You need to log in before you can comment on or make changes to this bug.