Bug 313141 - Module-zeroconf fails to advertise when sink name > 64 bytes
Module-zeroconf fails to advertise when sink name > 64 bytes
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 12:35 EDT by Jonathan Dieter
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.9.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-29 20:09:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix avahi names that are > 64 bytes (2.45 KB, patch)
2007-09-30 12:35 EDT, Jonathan Dieter
no flags Details | Diff
Spec file that includes patch (13.46 KB, text/plain)
2007-09-30 12:38 EDT, Jonathan Dieter
no flags Details

  None (edit)
Description Jonathan Dieter 2007-09-30 12:35:57 EDT
module-zeroconf in 0.9.6 will fail to advertise a sink or source if the size of
the name is greater than 64 bytes (which, while not common, does happen,
especially with emu101k sound cards).

Attached is the 0.9.7 fix backported to 0.9.6
Comment 1 Jonathan Dieter 2007-09-30 12:35:57 EDT
Created attachment 211861 [details]
Patch to fix avahi names that are > 64 bytes
Comment 2 Jonathan Dieter 2007-09-30 12:38:57 EDT
Created attachment 211871 [details]
Spec file that includes patch

Here's the spec file
Comment 3 Lennart Poettering 2007-10-15 13:01:56 EDT
I will commit an update package shortly.
Comment 4 Lennart Poettering 2007-11-29 20:09:48 EST
Since F8 has been released I will close this bug now.

Note You need to log in before you can comment on or make changes to this bug.