Bug 313241 - nv driver fails to work; fedora fails to boot every other time with nvidia driver
nv driver fails to work; fedora fails to boot every other time with nvidia dr...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 14:07 EDT by Colin Ely
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 19:59:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Ely 2007-09-30 14:07:18 EDT
Description of problem:
the nv driver does not work with the nvidia quadro fx570m.  The proprietary
nvidia driver works, but fedora fails to boot on every other attempt.  Fedora
must be restarted improperly by holding the power button for it to boot the next
time, or it hangs at a blank screen.  The screen also fails to dim if running on
battery power, and suspend does not work.

How reproducible:
every time

Steps to Reproduce:
1. complete a text install of f7 and fully update it, on a computer with the
nvidia quadro fx570m card.
2. install the proprietary nvidia driver
3. edit /etc/inittab so fedora boots to runlevel 5 by default
4. reboot the computer

  
Actual results:
fedora 7 hangs at a blank screen

Expected results:
fedora 7 boots correctly
Comment 1 Matěj Cepl 2007-10-01 19:59:31 EDT
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo
Comment 2 Colin Ely 2007-10-01 20:21:52 EDT
Well, there are two issues here.  One being the problem that fedora fails to
boot every other time with the proprietary nvidia driver, and I cannot tell
whether the source of that problem lies with the nvidia driver, or fedora.  It
can be resolved, though, because sabayon boots on the same computer every time
with the nvidia driver enabled.

the second problem is that the nv driver fails to work completely with this
videocard, and that is clearly an open source problem.
Comment 3 Matěj Cepl 2007-10-02 06:20:29 EDT
Read, what I have pasted there -- go ahead and reopen the bug if you are able to
reproduce the problem with nv driver AND ATTACH THE LOG FROM THAT CONFIGURATION.
That's the point -- we need to see what nv driver sees on your computer (which
is unfortunately not the same what nvidia driver sees).

Note You need to log in before you can comment on or make changes to this bug.