Bug 313251 - rhythmbox hangs during playback
rhythmbox hangs during playback
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
7
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 14:48 EDT by Hollis Blanchard
Modified: 2007-12-14 13:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-14 13:44:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sysrq-t output after audio hang (6.01 KB, text/plain)
2007-09-30 14:48 EDT, Hollis Blanchard
no flags Details
gdb thread backtrace (11.52 KB, text/plain)
2007-09-30 17:21 EDT, Hollis Blanchard
no flags Details
backtrace from mp3 hang (12.02 KB, text/plain)
2007-10-03 19:17 EDT, Hollis Blanchard
no flags Details
normal rhythmbox thread state (17.13 KB, text/plain)
2007-10-03 19:26 EDT, Hollis Blanchard
no flags Details

  None (edit)
Description Hollis Blanchard 2007-09-30 14:48:11 EDT
Description of problem:
Audio stops while playing Ogg files. The UI is still responsive, but clicking a
button like Pause or Next cause the UI to stop refreshing.

Version-Release number of selected component (if applicable):
rhythmbox-0.10.0-8.fc7

How reproducible:
It has done this about 5 times in the past hour, when playing an album that was
just imported (using the same version of Rhythmbox).

Steps to Reproduce:
1. Insert CD.
2. Click "Copy to Library"
3. Select CD in the library and click "Play".


Additional info:
"rhythmbox -d" provides no unusual output. A DB polling thread appears to
continue functioning fine even after audio stops. Sysrq stack trace is similarly
uninteresting.
Comment 1 Hollis Blanchard 2007-09-30 14:48:11 EDT
Created attachment 211881 [details]
sysrq-t output after audio hang
Comment 2 Hollis Blanchard 2007-09-30 14:51:25 EDT
This is occurring on a dual-core PowerMac G5.
Comment 3 Bastien Nocera 2007-09-30 15:24:30 EDT
Please test with rhythmbox-0.10.1-2.fc7 in updates-testing. In the future,
please attach a user-space backtrace, I know you kernel guys like your SysRq+Ts :)
Comment 4 Hollis Blanchard 2007-09-30 16:49:52 EDT
It looks like my yum only found rhythmbox-0.10.1-1.fc7, and it is still
affected. (I assume the -1 to -2 difference is only packaging, so this
information is still relevent.)
Comment 5 Hollis Blanchard 2007-09-30 17:21:22 EDT
Created attachment 211921 [details]
gdb thread backtrace

This is the output of "thread apply all bt" in gdb, with some debuginfo RPMs
installed.
Comment 6 Hollis Blanchard 2007-10-03 19:17:44 EDT
Created attachment 215261 [details]
backtrace from mp3 hang

Hang also affects mp3 playback, but can take a while to manifest (approx 30
mins this time). mp3 playback also occasionally stutters, but less often than
Vorbis FWIW.
Comment 7 Hollis Blanchard 2007-10-03 19:26:15 EDT
Created attachment 215271 [details]
normal rhythmbox thread state

For completeness, this backtrace was generated after interrupting a
perfectly-running rhythmbox.
Comment 8 Hollis Blanchard 2007-10-27 12:59:20 EDT
Problem does not affect VLC mp3 playback. Since VLC directly uses /dev/snd, that
probably rules out a bug in the ALSA driver, leaving rhythmbox and gstreamer as
candidates.
Comment 9 Hollis Blanchard 2007-12-14 13:44:45 EST
I haven't been able to reproduce this problem in Fedora 8.

Note You need to log in before you can comment on or make changes to this bug.