Bug 313291 - Mutt reacts incorrectly to SIGINT (Ctrl-C)
Summary: Mutt reacts incorrectly to SIGINT (Ctrl-C)
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mutt (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Honza Horak
QA Contact: Lukas Zachar
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-30 20:17 UTC by Jan "Yenya" Kasprzak
Modified: 2013-04-12 19:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-06 14:23:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch to allow interrupt in getch (674 bytes, patch)
2007-10-03 17:49 UTC, Miroslav Lichvar
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1143 normal SHIPPED_LIVE mutt bug fix update 2012-08-06 18:20:04 UTC

Description Jan "Yenya" Kasprzak 2007-09-30 20:17:28 UTC
Version-Release number of selected component (if applicable):
mutt-1.4.2.2-3.0.2.el5.x86_64

How reproducible:
100%

Steps to Reproduce:
1. run mutt
2. press / - mutt displays the "Search for:" prompt.
3. press Ctrl-C
  
Actual results:
nothing happens. Only after the next key is pressed, mutt displays the
Ctrl-C question:
"Exit Mutt? ([yes]/no):"
when "no" is chosen, mutt remains in the search mode, but the "Search for:"
prompt is not redrawn, leaving the user confused on what to do next.

Expected results:
mutt should display the "Exit Mutt?" question immediately after Ctrl-C is
pressed. When "no" is chosen, the search string and prompt should be redrawn, or
mutt should leave the search mode altogether (which is what mutt-1.5 does).

Additional info:
mutt-1.5.14-4.fc7 on Fedora system does not have this problem.
vanilla mutt-1.5.16 (from mutt.org), compiled with "./configure
--prefix=/usr/local; make; make install" on RHEL 5 also does not have this problem.

I have tested this only on x86_64 systems (both RHEL 5 and Fedora 7), but since
I don't think an architecture-specific bug is likely, I am leaving the Platform:
tag set to "All".

Comment 1 Miroslav Lichvar 2007-10-03 17:49:35 UTC
Created attachment 214881 [details]
upstream patch to allow interrupt in getch

Comment 2 Jan "Yenya" Kasprzak 2007-10-05 12:03:25 UTC
mutt-1.4.2.2-3.0.2.el5.x86_64 + the patch from comment #1 works for me. Thanks!

Comment 3 RHEL Product and Program Management 2007-12-03 20:46:42 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.

Comment 4 RHEL Product and Program Management 2008-07-21 23:09:08 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 14 errata-xmlrpc 2012-08-06 14:23:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1143.html


Note You need to log in before you can comment on or make changes to this bug.