This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 31332 - scsi DVD-RAM drive seen only as CDROM
scsi DVD-RAM drive seen only as CDROM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-09 22:55 EST by Clark Tompsett
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:38:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clark Tompsett 2001-03-09 22:55:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.19 i586)


Toshiba scsi DVD-RAM is seen only as cdrom.  Code maintainers for the
DVD-RAM backport show that the code to make DVD-RAM appear and work as
removable media.  Currently testing with rawhide 2.4.2 kernel.

Reproducible: Always
Steps to Reproduce:
1.Boot 2.4.2 kernel with scsi DVD-RAM attached and powered on
2.check system log file.  DVD-RAM identified but only set to CDROM. 
DVD-RAM media is not accessable as removable media for read/write
operatons.
3.
	

Expected Results:  scsi module should have code to set DVD-RAM to removable
media
Comment 1 Alan Cox 2001-03-12 23:33:34 EST
Im confused. DVD-RAM should appear and work read/write without patches in 2.4
Comment 2 Arjan van de Ven 2001-03-13 04:15:29 EST
Does a regular 2.4.2  work? And what 2.4.2. Red Hat Linux kernel failed (the
exact version number) ?
Comment 3 Clark Tompsett 2001-03-13 21:58:41 EST
have version 2.4.2-19 kernel from rawhide.  Toshiba sd-w1101 DVD-RAM drive
scsi.  Drive should appear as /dev/sdf on my system.  Log shows only cdrom, when
it should appear as a removable drive.  This drive reads cdroms, dvd, and writes
to a 2.6gb read/writeable optical cartrage.  This is a copy of the boot log:
<4>scsi : 1 host.
<6>(scsi0:0:0:0) Synchronous at 10.0 Mbyte/sec, offset 15.
<4>  Vendor: CWS ORB2  Model: -SE U ID 0        Rev: D42 
<4>  Type:   Direct-Access                      ANSI SCSI revision: 02
<4>Detected scsi removable disk sda at scsi0, channel 0, id 0, lun 0
<4>  Vendor: HP        Model: C2500A            Rev: 3332
<4>  Type:   Processor                          ANSI SCSI revision: 02
<4>  Vendor: YAMAHA    Model: CRW4260           Rev: 1.0q
<4>  Type:   CD-ROM                             ANSI SCSI revision: 02
<4>Detected scsi CD-ROM sr0 at scsi0, channel 0, id 3, lun 0
<6>(scsi0:0:4:0) Synchronous at 5.0 Mbyte/sec, offset 15.
<4>  Vendor: CONNER    Model: CTT8000-S         Rev: 1.07
<4>  Type:   Sequential-Access                  ANSI SCSI revision: 02
<4>  Vendor: IOMEGA    Model: ZIP 100           Rev: N*32
<4>  Type:   Direct-Access                      ANSI SCSI revision: 02
<4>Detected scsi removable disk sdb at scsi0, channel 0, id 5, lun 0
<6>(scsi0:0:6:0) Synchronous at 10.0 Mbyte/sec, offset 15.
<4>  Vendor: TOSHIBA   Model: SD-W1101 DVD-RAM  Rev: 1030
<4>  Type:   CD-ROM                             ANSI SCSI revision: 02
<4>Detected scsi CD-ROM sr1 at scsi0, channel 0, id 6, lun 0
<6>(scsi0:0:8:0) Synchronous at 20.0 Mbyte/sec, offset 8.
<4>  Vendor: IBM       Model: DNES-309170W      Rev: SAH0
<4>  Type:   Direct-Access                      ANSI SCSI revision: 03
<4>Detected scsi disk sdc at scsi0, channel 0, id 8, lun 0
<6>(scsi0:0:9:0) Synchronous at 20.0 Mbyte/sec, offset 8.
<4>  Vendor: QUANTUM   Model: VIKING 4.5 WSE    Rev: 880R
<4>  Type: Mar  5 06:30:32 localhost syslog: syslogd startup succeeded

You can fdisk the drive /dev/scd1 only of you provide h/c/s information.  

Comment 4 Arjan van de Ven 2001-03-14 04:37:02 EST
Have you tried
mke2fs /dev/scd1
or
mke2fs /dev/sr1
?


Comment 5 Clark Tompsett 2001-03-14 22:47:23 EST
tried your suggestion.. all it did was start to format the disk then put the
scsi bus into infinte bus resets. (aic7xxxx).  locked the system tight forcing
hard reboot.  not acceptable.
Comment 6 Arjan van de Ven 2001-03-15 04:45:32 EST
Doug, any idea what the origine of this can be ?
Comment 7 Doug Ledford 2001-03-15 12:48:09 EST
From looking at the code in scsi_scan.c it looks like the problem is that the
Toshiba DVD-RAM drive returns a device code of CD-ROM on Inquiry.  You only know
it is a DVD-RAM drive if you check things that linux doesn't normally check. 
Adding a blacklist entry of BLIST_ISDISK for all TOSHIBA DVD-RAM drives would be
next to impossible because they decided to put the model code *before* the
DVD-RAM tag in the Inquiry data instead of after, and our matching code wants to
be able to match from the start of the string until the end of our match
specifier.  That would require one blacklist entry per model of DVD-RAM drive
Toshiba sells.  Is there a manual to this DVD-RAM drive somewhere, and possibly
a jumper for the drive to make it return a more reasonable device type?  If not,
then the only way I know to go forward is to get the raw Inquiry data and see
what is being set to indicate that this is a DVD-RAM drive instead of a CD-ROM
drive since the device is actually returning a CD-ROM device code.
Comment 8 Clark Tompsett 2001-03-15 20:07:20 EST
Updated kernel to 2.4.2-0.1.25.  I was able to format the DVD-RAM.  However,
attempting to copy 39mb of data files to device failed.  Only the first couple
of files transfered, then started getting io errors, timeout errors, and bus
resets, that I had to reboot.  fsck reported so many errors, had to reformat the
disk.  

Also, putting the dvd-ram disk in the drive after formating resulted in bus
resets and hang even with an entry in the fstab identifing the drive as having
the ext2 filesystem.
Comment 9 Bugzilla owner 2004-09-30 11:38:56 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.