This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 31356 - mount should ignore the 'kudzu' option in fstab.
mount should ignore the 'kudzu' option in fstab.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-10 11:02 EST by Sam Varshavchik
Modified: 2007-04-18 12:32 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-13 07:06:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sam Varshavchik 2001-03-10 11:02:02 EST
Installed RC2.  There's an IDE floppy on /dev/hda.  Kudzu wrote the
following to /etc/fstab:

/dev/hda  /mnt/ls120.0    auto    noauto,owner,kudzu 0 0


"mount /dev/hda" or "mount /mnt/ls120.0" fails.  I have to explicitly write
everything out "mount -t ext2 /dev/hda /mnt/ls120.0".

Experimentation showed that mount was passing the "kudzu" option directly
to the kernel, and the kernel mount fails because it does not recognize
this non-standard option:

mount -t ext2 -o nosuid,noexec,kudzu /dev/hda /mnt/ls120.0

This does not work (that's what the kernel gets from a plain "mount /dev/hda").

mount -t ext2 -o nosuid,noexec /dev/hda /mnt/ls120.0

This does.

mount should ignore any "kudzu" option it finds in fstab.
Comment 1 Bernhard Rosenkraenzer 2001-03-12 12:47:26 EST
I could work around this in mount, but I'm not sure it's the right thing to do.
Michael, should the kernel ignore the kudzu option or should mount strip it 
off?
Comment 2 Glen Foster 2001-03-12 14:20:31 EST
This defect considered MUST-FIX (show-stopper) for Florence GOLD
Comment 3 Michael K. Johnson 2001-03-12 23:45:01 EST
Strip it off in mount.  It's a special-case option that the kernel should
not be burdened with dealing with, and dealing with it in mount is better.
Policy goes in user-space whenever possible.

The kudzu option was added because ewt thought it didn't break anything.
Looks like he was wrong...
Comment 4 Erik Troan 2001-03-13 07:06:19 EST
It looks like it. The bit that surprises me is that I tested mounting a couple
of pieces of media w/ the kudzu flag and auto and it worked fine.

I'll patch this in mount this afternoon.
Comment 5 Erik Troan 2001-03-13 10:53:55 EST
Added a patch to mount package to make it ignore the kudzu option.

Note You need to log in before you can comment on or make changes to this bug.