Bug 313581 - wine: Missing font files cause wine to render strange letters
wine: Missing font files cause wine to render strange letters
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-01 04:24 EDT by Bjorge Solli
Modified: 2008-06-16 22:33 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-06-16 22:33:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
output from command winecfg (23.58 KB, text/plain)
2007-10-08 10:43 EDT, Bjorge Solli
no flags Details
winecfg log of errors (23.57 KB, text/plain)
2007-10-09 07:22 EDT, Bjorge Solli
no flags Details

  None (edit)
Description Bjorge Solli 2007-10-01 04:24:41 EDT
Description of problem:
Wine uses some arabic font in it's programs, also configuration. If I downgrade
to the previous version everything is fine.

Version-Release number of selected component (if applicable):

How reproducible:
start any wine program from the gnome menu
Actual results:
some arabic (?) text/font in menus and messages

Expected results:
english text

Additional info:
If I downgrade to 0.9.36-2.fc7 it works as expected.
Problem is known to have happened to others on the fedora-list@redhat.com,
Message-Id: <200709281833.33194.colin@g6avk.demon.co.uk>
Comment 1 Andreas Bierfert 2007-10-08 09:55:08 EDT
Please backup your ~/.wine directory (e.g. move it to ~/.wine-save) and run e.g.
winecfg. This will create a new ~/.wine directory. This should solve your problems.
Comment 2 Bjorge Solli 2007-10-08 10:43:03 EDT
Created attachment 219801 [details]
output from command winecfg

No this does not help. See attached file.
Comment 3 Andreas Bierfert 2007-10-08 17:11:01 EDT
Outch... that does not look healthy. I wonder where the libGL errors come from?
Any problems with 3D graphics? I would also ask you to try 0.9.46 from
updates-testing just so that we are on the same version makes it easier for me
to verify bugs...
Comment 4 Bjorge Solli 2007-10-09 07:22:15 EDT
Created attachment 221141 [details]
winecfg log of errors

I haven't gotten 3D to work, but then I haven't tried very hard either. The
updates-testing repo only found a 0.9.45-1.fc7, and I tried this.

yum --enablerepo=updates-testing install wine

The repofile uses 

I also tried with 

I made sure to remove my .wine-dir first then ran winecfg (winecfg >wine.log2
2>&1) again. The same thing happens, see the logfile.
Comment 5 Bjorge Solli 2007-10-11 03:24:23 EDT
Hm. The attachment did not trigger the status. Hope this will.
Comment 6 Luis Felipe Marzagao 2007-10-11 20:57:56 EDT
Same problem here. Arabic letters everywere, including winecfg app.
Comment 7 Vang Be Pha 2007-10-11 22:16:47 EDT
Yep same problem here... I'm not sure what it could be... I installed wine to
use uTorrent and I can't even read it... and this is for F8 
Comment 8 Luis Felipe Marzagao 2007-10-11 22:25:27 EDT
Hello Vang: I don't mean to get out of topic, but have you tried ktorrent. I'm
pretty sure it's way better than utorrent+wine.

Aside from that, it would be nice if this bug was corrected in wine. Cheers
Comment 9 Bjorge Solli 2007-10-17 06:59:02 EDT
If I put some more fonts in /usr/share/wine/fonts (found them on windows) then
it works. How long till you can update the rpm in extras? I have some hundred
machines running fedora 7 and wonder if I should bother packing the files or
just wait for your update.
Comment 10 Luis Felipe Marzagao 2007-10-17 20:24:15 EDT
Great: Adding fonts from windows in /usr/share/wine/fonts indeed solves the problem!
Comment 11 Andreas Bierfert 2007-10-18 03:41:04 EDT
Thats interesting to know. Could you please single out the issue a bit more to
narrow it down to maybe one font that is missing? While I obviously cannot add
windows fonts to the wine package I am quiet stunned by the fact that some fonts
are missing for you. If I know which one is missing there might be a way around
the issue.
Comment 12 Bjorge Solli 2007-10-18 05:31:26 EDT
Actually; Including any one True Type Font (*.ttf) made wine use that font
(added one, tested, removed, tried another one). I did notice however that
marlett.ttf did not help. I tested about 10 ttf before skipping to *.fon.
None(!) of the .fon files helped. Summary: I don't know which of the fonts it
chooses when I add all, but I am sure it is one of the true type fonts.
Comment 13 Bjorge Solli 2007-10-18 05:37:57 EDT
I did find by stracing wine that it tries and fails to find these fonts:

I found serife.fon (and put it in /usr/share/wine/fonts, but that one did not
help. Did not find the other two.
Comment 14 Bug Zapper 2008-05-14 10:35:31 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 Bug Zapper 2008-06-16 22:33:14 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.