Bug 31393 - bind 8 -> 9 migration problems
bind 8 -> 9 migration problems
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-10 20:32 EST by Ulrich Drepper
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-10 20:32:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2001-03-10 20:32:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-prerelease i686; en-US; 0.9)
Gecko/20010223


After upgrading my system from RH7 to Wolferine I had only one major
problem.  Bind 9 is more picky about the zone data.  I had no $TTL line in
the zones.  The starting bind 9 *warned* about the missing TTL but then
didn't serve these zones.  Upstream servers worked but this server is the
master for one zone.  The result was that the entire networked stopped working.

The bind 9 documentation is less than helpful.  There is no usage manual,
just the reference.  There is no description of the sort of reaction one
should expect from this kind of error.  And the ISC is of course not
interested in providing this since they want to sell services.

Reproducible: Always
Steps to Reproduce:
1.get a system with bind 8 and zone maps without $TTL lines
2.upgrade the system
3.try using the system
	

Actual Results:  The local zones are not served.

Expected Results:  There is not much the installation can do to prevent the
actual problem.  But there should be a trouble-shooting guide for the bind
9 upgrade.
Comment 1 Bernhard Rosenkraenzer 2001-03-11 05:45:25 EST
Actually there is such a document, it's located in 
/usr/share/doc/bind-9.1.0-8/misc/migration

However, since many people won't read docs, I've patched bind to work with 
broken zone files (simply defaulting to TTL=86400, as with bind 8) and spew 
out a big fat warning in syslog. (9.1.0-9)



Note You need to log in before you can comment on or make changes to this bug.