This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 3140 - On sparc64, mkswap sets incorrect bits in bitmap
On sparc64, mkswap sets incorrect bits in bitmap
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
6.0
sparc Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-29 09:14 EDT by Jeff Johnson
Modified: 2015-01-07 18:37 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-05-29 14:10:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnson 1999-05-29 09:14:27 EDT
Some changes to recent 2.3.4-pre kernels pointed out this
bug.
The mkswap tool on sparc64 would set the wrong bits in the
swappage
bitmap in the signature for version 0 swap partitions (the
issue is
that on big endian it matters what size the unit of words is
for
bitmaps).

This is deadly, and if users report bugs where their
UltraSparc's spit
out messages such as "attempt to read past end of device" or
similar,
and the device number printed out turns out to be one of
their swap
devices, this is indeed the bug they are seeing.

This is against the current 6.0 util-linux SRPM and builds
just fine.

Please put out an errata for this at next convenience,
thanks a lot.
Comment 1 Jeff Johnson 1999-05-29 14:10:59 EDT
Fixed (by applying patch) in util-linux-2.9o-14.

Note You need to log in before you can comment on or make changes to this bug.