Bug 314121 - NetworkManager shows disconnected icon if the connection is already up
NetworkManager shows disconnected icon if the connection is already up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-01 12:33 EDT by Michel Alexandre Salim
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 11:14:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2007-10-01 12:33:11 EDT
Description of problem:
Whenever I boot my laptop with the eth0 network card connected to the wired
network (it's set to be activated on boot), when logging on the NetworkManager
icon is still showing a disconnected status. The icon is updated if I tell NM to
reconnect.

Version-Release number of selected component (if applicable):
NetworkManager-0.7.0-0.3.svn2907.fc8

How reproducible:
Always

Steps to Reproduce:
1. Enable a network connection manually
2. Log in to a graphical desktop
  
Actual results:
NM tray icon shows up as disconnected

Expected results:
NM tray icon shows as connected

Additional info:
This has been present for several releases in the 0.7.0 series. I've not tried
the latest build -- yum update shows some conflicts on x86_64, I think some of
the i386 packages have not been pushed.
Comment 1 Jeremy Katz 2007-10-04 13:33:32 EDT
I think we got this fixed upstream on Monday -- need to get a new snapshot into
rawhide.
Comment 2 Will Woods 2007-10-19 18:03:05 EDT
Seems to work as expected in current rawhide
(NetworkManager-0.7.0-0.3.svn2983.fc8), except for one minor thing.

When NetworkManager was first enabled on a fresh install, it showed the network
as disconnected, even though the connection *had* been up before that. Checking
ifconfig I noticed that the connection was, in fact, now down.

I told nm-applet to connect to the wired network, and it connected. And now, as
mentioned, the connection works fine for me at every login. 

Michel, does NetworkManager work for you now?
Comment 3 Michel Alexandre Salim 2007-10-25 15:33:57 EDT
Using NetworkManager-0.7.0-0.3.svn3020.fc8, problem still persists.

- Boot computer
- Drop to a terminal and bring eth0 up manually (/sbin/ifup eth0)
- Log in
- Verify that browsing works, Mugshot client connects, etc. but NM still claims
connection is disconnected

Comment 4 Dan Williams 2007-10-25 17:25:30 EDT
NetworkManager will not recognize manually changed due to manual interface
control, like using ifup.  That's expected and not a bug.

Michel, can you ensure that you have checked the 'autoconnect' box in GConf for
your ethernet connection?  It'll be in /system/networking/connections and in the
'connection' directory of a connection under that path.  You're looking for the
'Auto Ethernet' connection.  That will tell NM to connect to the wired network
automatically when it can.  Before and including Test 3, the autoconnect bit was
not checked by default for other reasons.
Comment 5 Michel Alexandre Salim 2007-11-03 15:33:05 EDT
The key does not exist -- does the default GConf schema for NM include it?

Slightly OT, but is nm-connection-editor supposed to be working? I have to run
it manually, and it does not list my existing connections.
Comment 6 Dan Williams 2007-11-03 15:41:00 EDT
do you have anything under /system/networking/connections at all?  The
connection editor isn't yet working; that's why its disabled from the
right-click menu of the applet.
Comment 7 Michel Alexandre Salim 2007-11-04 18:41:12 EST
Ah, funny, it's there now after restarting the system. When editing, I do get a
warning that the keys have no schema -- will this be fixed for F8 final?
Comment 8 Dan Williams 2007-11-06 11:14:05 EST
schema stuff wont; schemas will get added later but aren't critical.  sounds
like its working now for you, thanks.

Note You need to log in before you can comment on or make changes to this bug.