Bug 314281 - SELinux blocks AdobeReader 8 Browser Plugin
SELinux blocks AdobeReader 8 Browser Plugin
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy-targeted (Show other bugs)
5.0
i686 Linux
low Severity high
: ---
: ---
Assigned To: Daniel Walsh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-01 13:50 EDT by Heiko Adams
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 16:19:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Heiko Adams 2007-10-01 13:50:50 EDT
Description of problem:
The SELinux policies shipped with RHEL 5 are preventing the Adobe Reader 8
browserplugin from being loaded.

Version-Release number of selected component (if applicable):
selinux-policy-targeted-2.4.6-30.el5
AdobeReader_enu-8.1.1-1

How reproducible:
allways

Steps to Reproduce:
1. Install Adobe Reader 8
2. Start Firefox from a shell
3. Navigate to about:plugins
  
Actual results:
LoadPlugin: failed to initialize shared library
/opt/Adobe/Reader8/Browser/intellinux/nppdf.so
[/opt/Adobe/Reader8/Browser/intellinux/nppdf.so: Kann den Segment-Schutz nach
der Relozierung nicht wieder herstellen: Keine Berechtigung]

Expected results:
The plugin should be loaded without any interception of selinux

Additional info:
The problem was discovered on a CentOS 5 System but it should even affect RHEL 5
systems too.
Comment 1 Daniel Walsh 2007-10-01 16:19:44 EDT
We have never seen this package installed in this location.

You can fix this by executing the following commands

semanage fcontext -a -t textrel_shlib_t
/opt/Adobe/Reader8/Browser/intellinux/nppdf.so

restorecon -v /opt/Adobe/Reader8/Browser/intellinux/nppdf.so

If this is a standard package the path in the RHEL5 bas should be updated.

Note You need to log in before you can comment on or make changes to this bug.